Ticket #1897 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

OM2008.8-upgrade: PIN dialog not showing up

Reported by: Yorick Owned by: zecke
Priority: highest Milestone: Om2008.9
Component: Qtopia Version: Om2008.8
Severity: blocker Keywords: PIN
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

PIN dialog does not show up:
I have a fully upgraded 2008.8-upgrade, and have not changed the feeds.

Since I didn't get any luck with the qtopia dialer I installed the openmoko-dialer2
So I should delete one of the dialers?

I rebooted 2008.8 and the PIN dialog doesn't show up so when I try the qtopia-dialer it says of course no network...

After opening openmoko-dialer2 I try to call and get the error message "Method "Dial" with signature "s" on interface "org.openmoko.PhoneKit??.Dialer" doesn't exist". Immediatly after this error message I get a new sms message (strange, no? i'm still not registered) and immediatly after this message the pin dialog of openmoko-dialer2 shows up.
My network icon says I have good reception (green) but when I press Dial, it says "Dialer Error: No Network".

I close openmoko-dialer2.

I open the qtopia-messages and I see no new message...

I close qtopia-messages.

I open qtopia-dialer
I dial my number
It says (Dialing) but I hear no sound and my speakers also do not respond like they do when I dial.

I press disconnect.

I once again try openmoko-dialer2 in vain.

Logread and opkg list_installed is attached.

I then uninstalled openmoko-dialer2
rebooted
No pin-dialog
opened qtopia-dialer
dialed and got of course the no network not registered thing
waited....
re-opened qtopia-dialer
dialed
same result
waited....
waited....
waited....
gave it up and did logread and lsit_installed

(I googled but couldn't find the commands to force the PIN dialog...)

Attachments

logread.txt (63.9 KB) - added by Yorick 10 years ago.
logread two dialers
list_installed.txt (46.2 KB) - added by Yorick 10 years ago.
list_installed two dialers
logread_no_openmoko-dialer2.txt (64.0 KB) - added by Yorick 10 years ago.
logread only qtopia-dialer
list_installed_no_openmoko-dialer2.txt (46.2 KB) - added by Yorick 10 years ago.
list_installed only qtopia-dialer

Change History

comment:1 Changed 10 years ago by Yorick

sorry I forgot to edit the title:
should be 2008-upgrade: PIN dialog not showing up
(but I can't edit the title anymore..)

Changed 10 years ago by Yorick

logread two dialers

Changed 10 years ago by Yorick

list_installed two dialers

Changed 10 years ago by Yorick

logread only qtopia-dialer

Changed 10 years ago by Yorick

list_installed only qtopia-dialer

comment:2 Changed 10 years ago by Yorick

looks like I shouldn't have opened this one also (I did it because https://docs.openmoko.org/trac/ticket/1766#comment:86 said to do it, but https://docs.openmoko.org/trac/ticket/1766#comment:87 seems to say it doesn't need a new bug report)
So please close this ticket

comment:3 Changed 10 years ago by wendy_hung

  • Summary changed from OM2008.8-upgrade to OM2008.8-upgrade: PIN dialog not showing up

comment:4 Changed 10 years ago by erin_yueh

  • Status changed from new to closed
  • Resolution set to fixed

according to the reporter, mark it as fixed!

Note: See TracTickets for help on using tickets.