Ticket #1901 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

Answer button does not work

Reported by: Zoup Owned by: zecke
Priority: highest Milestone:
Component: Qtopia Version: Om2008.8
Severity: critical Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

Answer button does not answer phone calls , it just get 'clicked' and nothing happnes .

Om2008.8-gta02-20080829.rootfs.jffs2
Om2008.8-gta02-20080826.uImage.bin

this happens after latest stable updates

Attachments

logread+opkg_list_installed.txt (75.2 KB) - added by octavsly 10 years ago.
Output of logread after answer button did not do anything + list of installed packages
messages (4.9 KB) - added by Zoup 10 years ago.
messages
installed_packages (43.4 KB) - added by Zoup 10 years ago.
list of installed packages

Change History

comment:1 Changed 10 years ago by zecke

  • Status changed from new to closed
  • Resolution set to invalid

http://wiki.openmoko.org/wiki/Bug_Filing_Policy. GSM bug and I don't see opkg list_installed and the output of logread.

comment:2 Changed 10 years ago by octavsly

I just had the same issue few minutes ago.

I will attach the two outputs in one file (logread+opkg_list_installed.txt).

I need to leave it as closed since I have no permission to change the ticket field.

Changed 10 years ago by octavsly

Output of logread after answer button did not do anything + list of installed packages

comment:3 Changed 10 years ago by zecke

Bogus log. I don't even see an incoming call in it.

comment:4 Changed 10 years ago by zecke

You can see an incoming call with +RING and %CPI messages... then an ATA or AT+CHLD should be executed... all of them are not visible... please provide a better log.

comment:5 Changed 10 years ago by octavsly

  1. It would be tricky to reproduce. This happened only once. Furthermore, I have updated to the lateste packages :-)
  1. Is there a way to store the log on the SD card? /var/log/messages ?
  1. Is there a way to save a bigger log file?
  1. Is there a way to preserve a log when phone is shutdown?

Thank you,
Octavian

comment:6 Changed 10 years ago by zecke

1.) Just keep an eye open.

2.-4.)
We use busybox's syslogd. The documentation of it can be found at http://busybox.net. It should be possible to make it log to a file (our default is a ringbuffer), it should be possible to make it log more (/etc/syslog.conf) to the ringbuffer.

Changed 10 years ago by Zoup

messages

Changed 10 years ago by Zoup

list of installed packages

comment:7 Changed 10 years ago by Zoup

Same issue again , with om2008-update , let me know if there are any more detail needed.

comment:8 Changed 10 years ago by zecke

the messages file is rather short and does not even mention any kind of (try to answer, error, call gone...). Do you have a longer log entry?

comment:9 Changed 10 years ago by Zoup

Dear zecke ,

well , its in fact tail -f /var/log/messages since im logging to file system , this is short because i i let it log normal things , and i did just cut after calling FR , yes , nothing is logged because nothing happens when i press answer button ... you might want x.log but there isn't anything there as well ...

Note: See TracTickets for help on using tickets.