Ticket #191 (closed enhancement: wontfix)

Opened 12 years ago

Last modified 10 years ago

set CPU voltage to 1.8V on 200MHz or less

Reported by: laforge@… Owned by: willie_chen@…
Priority: high Milestone:
Component: Core System Version: GTA01Bv2
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The S3C2410 data sheet only specifies that the 266MHz CPU type requires 2.0V (we
run it at 2.1V), and the 200MHz variant requires 1.8V.

However, if we dynamically change the CPU speed of the 266MHz variant down to
200 (or below), can we safely reconfigure the voltage to 1.8V? If yes, this
would give us even more power savings than just reducing the clock rate by cpufreq.

Change History

comment:1 Changed 12 years ago by laforge@…

according to Samsung FAE reply, the voltage really depends on the actual used
frequency, rather than the component type. therefore we can safely switch to
lower voltage if we only use 200MHz

comment:2 Changed 12 years ago by laforge@…

  • Summary changed from investigate if we can set CPU voltage to 1.8V on 200MHz or less to set CPU voltage to 1.8V on 200MHz or less

according to Samsung FAE reply, the voltage really depends on the actual used
frequency, rather than the component type. therefore we can safely switch to
lower voltage if we only use 200MHz

comment:3 Changed 11 years ago by tick@…

  • Owner changed from sean_chiang@… to willie_chen@…

switch to willie

comment:4 Changed 11 years ago by willie_chen@…

It still has problem for GTA02. We need to check this.

comment:5 Changed 11 years ago by andy@…

  • Status changed from new to assigned

comment:6 Changed 10 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to wontfix

We ended up fixing the GTA02 clock at 400MHz, due to problems with supporting dynamic clock scaling on 2442. So we won't support dynamic voltage scaling on 24xx (except when the clock and core voltage are zero in suspend I guess).

I'm going through cleaning out older bugs that we don't really intend to target, as the amount of open bugs has gotten crazy and we can't see the wood from the trees. Please accept my apologies.

Note: See TracTickets for help on using tickets.