Ticket #1928 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Settings don't change the suspend time

Reported by: wilk Owned by: marek
Priority: normal Milestone: Om2008.9
Component: Settings Version:
Severity: blocker Keywords:
Cc: zecke@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

After today's (30/08) update from http://downloads.openmoko.org/repository/Om2008.8/, my freerunner doesn't suspend by itself, whatever the setting configured. I can however manually make it suspend (POW button) and wake up (POW button or a call).

I suspect that it's the Settings menu that doesn't change the apm parameters since other users reported that their Freerunner goes into suspend mode, but they can't change the time to suspend. I guess I'm just lucky that mine was configured for "no suspend" when I did the upgrade.

I'm running raster's image upgraded through official repos. I attach the output of opkg list_installed.

Attachments

list_installed.txt (41.3 KB) - added by wilk 6 years ago.
list_installed_tom_yates.txt (42.0 KB) - added by madhatter 6 years ago.

Change History

Changed 6 years ago by wilk

comment:1 Changed 6 years ago by madhatter

i'm having the same problem after the same update; /etc/angstrom-version says "Angstrom P1-Snapshot-20080830". my list of packages will also be attached.

Changed 6 years ago by madhatter

comment:2 Changed 6 years ago by Holger

I've updated my FR to kernel Om2008.8-gta02-20080826.uImage.bin / rootfs Om2008.8-gta02-20080831.rootfs.jffs2 tonight. After the update I do have the same problem: My FR always suspends after 30s regardless of the seetings I've configured. The second before the FR suspends it shows the logo of X Window System (but maybe I just missed the logo before the update).

comment:3 follow-up: ↓ 4 Changed 6 years ago by time.dragon

I have the same exact problem as Holger

comment:4 in reply to: ↑ 3 Changed 6 years ago by michal.penka

Replying to time.dragon:

I have the same exact problem as Holger

I think everybody has the problem...see http://docs.openmoko.org/trac/ticket/1932#comment:2

comment:5 follow-up: ↓ 6 Changed 6 years ago by gromgull

I have the same symptoms as Holger, although I believe the phone does not actually suspend. At least ssh sessions over wifi and usb-net stay up. I believe that for a true suspend wifi at least is shut down?
When in this state I cannot bring the phone back - and restarting the xserver will crash the phone completely.

However - I've successfully used illume-config to disable suspend all together, now the display remains on, but after 30s it displays the X logo in various sizes and positions. Almost like a screensaver? Very odd...

comment:6 in reply to: ↑ 5 Changed 6 years ago by flamma

Replying to gromgull:

I have the same symptoms as Holger, although I believe the phone does not actually suspend. At least ssh sessions over wifi and usb-net stay up.

That happened me once. But usually it stops all, or at least it stop the usb net.

When I wake up the phone, if I do not quit the black "screensaver" page, the phone doesn't suspend again..

comment:7 follow-up: ↓ 8 Changed 6 years ago by marek

  • Status changed from new to accepted

I can confirm this issue. I installed:
Om2008.8-gta02-20080901.rootfs.jffs2
Om2008.8-gta02-20080826.uImage.bin

I also see the X logo for a second. The neo suspends regardless the settings.
Holger, what did change recently ? Settings did not get updated.

comment:8 in reply to: ↑ 7 Changed 6 years ago by Holger

Replying to marek:

Holger, what did change recently ?

Do you ask me? I'm not Holger 'Zecke' Freyther (zecke at openmoko dot org), I'm just a device owner (I ask because you did not add Zecke to CC).

comment:9 Changed 6 years ago by marek

  • Cc zecke@… added

Oh, good hint! ;-)

comment:10 follow-up: ↓ 13 Changed 6 years ago by flamma

I have noticed today that when I stop the xserver, I can see in the phone screen, in the console, a lot of messages like "xset: cannot open display", or similar (now my screen doesn't turn on). I don't know if that is related. This time several wake up didn't brought up the black screen, but the desktop. Also don't know if that has relationship.

comment:11 Changed 6 years ago by gromgull

One more thing I just remembered - while in the black screen state I tried to use apm to actually suspend (apm -s), but it said something along the lines of "Device or resource busy" and refused to do anything.

comment:12 Changed 6 years ago by imrehg

Hi,

I tried newly flashed 0831 and 0901 rootfs images.
In both cases: after boot, I turned off the suspend mode, but the screensaver comes up nevertheless after a minute (that's the default setting, I think). During suspend all usb networking is stuck (maybe it is an "of course"?) so these images are totally useless, unless you are keep touching the screen.

The 0829 image was working fine.

comment:13 in reply to: ↑ 10 ; follow-up: ↓ 25 Changed 6 years ago by flamma

I have it again on screen. The exact message is:

xset: unable to open display ""

HTH

comment:14 Changed 6 years ago by flamma

I have installed illume-config-illume and have done all things I need to get the wrench to configure. Now, I can't change when the screen fades, but I can change how much time after fade the phone will suspend.

So, I think the real problem is that 2008.8 don't let you to configure when the screensaver rise, and how much time after that the phone should suspend.

comment:15 follow-up: ↓ 20 Changed 6 years ago by gromgull

As someone pointed out somewhere else, this is indeed the X screensaver, doing "xset s off" from the terminal will cause the X thing not to appear. The unable to open display happens when you try to do this without DISPLAY=:0 set.

Now turning off the screensaver leaves me what this ticket really is for. Setting blank or suspend times in the illume-config thingy doesn't actually change anything. Now it's just on all the time :)

Interestingly I cannot manually suspend either, the power button now brings up the X screensaver again.

comment:16 Changed 6 years ago by rost

I just want to join in here.
Because telephony on the Openmoko is in such a bad state, I wanted to use it at least as a GPS device. This bug makes the Openmoko even unusable for that. After starting tangoGPS and not touching anything for 30 sec my Openmoko goes into suspend. Not good.

comment:17 Changed 6 years ago by wilk

Last update. I upgraded to http://downloads.openmoko.org/repository/testing/

The phone never goes to suspend by itself, regardless of the time chosen either in "Settings" or in illume's configuration tool (the wrench). The setting for blanking the screen in illume's configuration tool is however honored.

The POW button does't put the phone in suspend mode (it doesn't do anything). However apm -s on a terminal does suspend the phone and POW wakes it up.

comment:18 follow-up: ↓ 19 Changed 6 years ago by hiciu

I think there is workaround for this issue. In xterm on freerunner or via ssh with "export DISPLAY=:0":

xset s 30 

After 30 seconds it will go sleep.

xset s off

It will never go sleep. It's work on my today-updated om2008.08. After resume you must tap screen to unblank it. I'm using only "stable" repos and my power button always put my freerunner in sleep.
(sorry for my bad English)

comment:19 in reply to: ↑ 18 Changed 6 years ago by wilk

Replying to hiciu:

I think there is workaround for this issue. In xterm on freerunner or via ssh with "export DISPLAY=:0":

xset s 30 

After 30 seconds it will go sleep.

Are you sure it's really sleeping. I thought mine was (stable image) but the battery drained in less than a day, as if it'd be on the whole day. Does it fade to black when you push POW (it does when it just blanks). Do you here the sound of the speaker coming back on line and see text flashing on a black background when you wake it up by pressing POW (what you get when it really wakes up from suspend) ?

comment:20 in reply to: ↑ 15 Changed 6 years ago by flamma

Replying to gromgull:

As someone pointed out somewhere else, this is indeed the X screensaver, doing "xset s off" from the terminal will cause the X thing not to appear. The unable to open display happens when you try to do this without DISPLAY=:0 set.

I am not talking about calls to xset I do (I know I have to select the correct display). I talk about calls that the phone make on its own. The phone is trying to xset something, and I thought it could be interesting (or not) to know.

comment:21 follow-up: ↓ 22 Changed 6 years ago by kapal

I confirm the workaround using xset s off. Using stable om2008.08 image from 20080802. Without this setting FR will blank (screensaver) and thus suspend (while connected via usb cable the ssh connection brakes).

comment:22 in reply to: ↑ 21 Changed 6 years ago by wilk

To summarize : there is at the moment no way to suspend the Freerunner from either the POW button or using the "Suspend Time" from Settings.

However, the "blank time" and "suspend after blank" from the Power setting of "the wrench" (from the illume-config package) are valid. So

  • if you want your Freerunner to suspend after 60s, set for example the blank time to 60s ant the suspend after blank to 1s.
  • if you don't want it to suspend at all (when plugged via usb), set the blank time to off.

Note that when you wake the phone, with the POW button, you'll have to tap the screen to get the screen back on since it wakes blank : something else that should be corrected.

I also noticed that since upgrading to OM2008.9 testing, it takes longer than before to wake up, something around 15". I timed it by putting the phone to sleep through apm -s (this way it doesn't wake up blank) or, if it wakes up blank by waiting for the sound of the speaker coming back on.

comment:23 Changed 6 years ago by marek

Ok, i looked into the issue today. The command given by hiciu fixes the problem:

xset s off

It disables the screensaver. After disabling it settings works as expected.
I have no clue why we have a running screensaver now. This has to be fixed by the distro team.

Probably,#1952 is the same issue.

comment:24 Changed 6 years ago by wendy_hung

  • Status changed from accepted to closed
  • Resolution set to fixed

Tested with the image:
kernel: Om2008.8-gta02-20080903.uImage.bin
rootfs: Om2008.8-gta02-20080904.rootfs.jffs2

It can set the suspend time off now, seems like the screensaver has been removed.

comment:25 in reply to: ↑ 13 Changed 6 years ago by h.koenig

Replying to flamma:

I have it again on screen. The exact message is:

xset: unable to open display ""

I see the same messages on the text console after stopping X.

this xset is called from "ompower" during suspend/resume
and ompower doesn't have $DISPLAY set:

F UID PID PPID PRI NI VSZ RSS WCHAN STAT TTY TIME COMMAND
0 0 1440 1 20 0 2660 776 wait S ? 0:00 ompower
0 0 2944 1440 20 0 2724 564 wait S ? 0:00 sh -c xset s reset

Note: See TracTickets for help on using tickets.