Ticket #193 (closed enhancement: wontfix)

Opened 12 years ago

Last modified 10 years ago

Information about current charging status when AC is online

Reported by: mickey@… Owned by: raster@…
Priority: normal Milestone:
Component: E - Illume Version: unspecified
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Ideally, we would like to be able forecast how long a charge is taking. If we
can't do that, then we'd like to know about the current status in percent. If we
can't even do that, please at the minimum, let us know when the battery is fully
charged.

Attachments

pmu-allow-neg-current.patch (1.1 KB) - added by alex@… 11 years ago.
Allow to read negative currents

Change History

comment:1 Changed 12 years ago by laforge@…

  • Status changed from new to assigned

comment:2 Changed 11 years ago by jluebbe@…

There is information in sysfs:

root@fic-gta01:~$ cat /sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/battemp
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/battvolt
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/chgcur
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/chgmode
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/chgstate
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/driver/
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/gta01-pm-bt.0/
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/gta01-pm-gps.0/
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/name
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/power/
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/subsystem/
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/uevent
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_d1reg
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_d2reg
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_d3reg
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_dcd
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_dcde
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_dcud
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_ioreg
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/voltage_lpreg

root@fic-gta01:~$ while true; do cat
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/battvolt; sleep 1; done;
3750
3744
3755
3750
3750
3738
3755
(unplugged)
3673
3650
3656
3650
3650
3650
3626
3650
3644
3650
(plugged in)
3750
3726
3720
3744
3732
3744
3726

root@fic-gta01:~$ while true; do cat
/sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/chgcur ; sleep 1; done;
1146
613
986
1013
826
853
880
773
933
(unplugged)
17367
17260
17474
17474
17447
(plugged in)
906
880
853
800
933
1146
960

It should be possible to use this information to detect when the battery is full.

comment:3 Changed 11 years ago by alphaone@…

  • dependson set to 255

comment:4 Changed 11 years ago by mickey@…

Alternatively we can stop charging, measure current, start charging again. This
depends on our ability to stop charging, of course (which doesn't work yet).
Adding another bug on that.

Changed 11 years ago by alex@…

Allow to read negative currents

comment:5 Changed 11 years ago by tick@…

  • Status changed from assigned to new
  • Owner changed from sean_chiang@… to willie_chen@…

comment:6 Changed 11 years ago by willie_chen@…

Was this patch accepted in kernel?

comment:7 Changed 11 years ago by andy@…

This should be resolved for GTA02 since it looks like we will be using smart
batteries with HDQ support, and the driver does export this information
down /sys

comment:8 Changed 10 years ago by andy

  • Status changed from new to assigned
  • Owner changed from willie_chen@… to raster@…
  • Component changed from PMU (Power Management Unit) to E - Illume

Reassigning to Raster since he is working on UI end. This isn't a PMU issue.

If he thinks that he gives this feedback already (eg battery level indication) then please close the bug.

comment:9 Changed 10 years ago by mickeyl

This was indeed a PMU issue hence the component was properly selected.

comment:10 Changed 10 years ago by raster

  • Status changed from assigned to closed
  • Resolution set to wontfix

there is nothing in the ASU specs that indicate the battery charge status should be displayed or not. thus this is not going to be done one way or another. the code can read it all and calculate time until full, time until empty, percentage full or empty and if charging is active. the rest is up to the theme to decide what to do - you can make the theme display anything you like, but given the battery size there isn't a lot of room to display both info that you have charging happing and battery level. asu design specifies a limited set of bars for the battery (even though the code calculates completely in percentages.

setting as wontfix as it's not in the gui ui spec and it's up to theme/skin design to decide what to do.

Note: See TracTickets for help on using tickets.