Ticket #194 (closed defect: fixed)

Opened 12 years ago

Last modified 2 years ago

s3c2410fb 8bit mode corrupt

Reported by: laforge@… Owned by: willie_chen@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The 8bit mode of s3c2410fb seems to be broken, at least in 2.6.20 there seems to
be a NUXI problem (byte swapping), since the fonts get rendered with the wrong
byte order. The palette / LUT is also broken, giving funny color effects

removing HWSWAP from the LCDCON registers did not solve the problem.

Change History

comment:1 Changed 12 years ago by stefan@…

Small update:

16bit: Working fine
8bit: Broken
4bit: Broken, but different from 8bit
2bit: Different broken again. Not able to launch matchbox.
1bit: Bluescreen only. Not even kernel messages.

Most important one is 8bit, perhaps 4bit. I think we can ignore 2bit and 1bit.

I'll continue with further debugging.

comment:2 Changed 12 years ago by laforge@…

8bit is important, we can forget about 2 and 4 bit (IIRC the 2410 can't do this
anyway), but 1bit would be nice if it is fixed, too.

comment:3 Changed 12 years ago by stefan@…

  • Owner changed from laforge@… to stefan@…

comment:4 Changed 12 years ago by stefan@…

Switching from half word swap to byte swap

  • S3C2410_LCDCON5_HWSWP,

+ S3C2410_LCDCON5_BSWP,

gives me a working text output on 16bit and 8bit. Colors in X are broken in both
deoths now.

With HWSWP text and colors works.

comment:5 Changed 12 years ago by stefan@…

With HWSWP text and colors works.

... with 16bit.

comment:6 Changed 12 years ago by stefan@…

I enabled the bootup logo to test the colors on the textconsole.

Using BSWP on 16BPP has a tint. HWSWP is the right choice for 16BPP. It gives
perfect textconsole and X.

For 8BPP BSWP is the right choice for the textconsole. The Tux has the right
color s. The problem with 8BPP start with the Xserver. When starting the xserver
the following appears:

can't get colormap: Invalid argument
alloc color failed
alloc color failed
...

comment:7 Changed 12 years ago by stefan@…

Funny observation: rxvt has the right colors, but only grey, white and black.
Same for other apps with disabled openmoko theme.

Icons are still broken

comment:8 Changed 12 years ago by stefan@…

To fix the BSWP vs. HWSWP setting problem I'm in contact with Ben Dooks. He's
thinking about the best integration of it.

I will open a new bug about the 8bit kdrive problem.

comment:9 Changed 12 years ago by stefan@…

Seems to be a better idea let the info in this bug.

Starting kdrive with 8bit gives the following error:

can't get colormap: Invalid argument

The errors occurs due to an failed ioctl: (hw/kdrive/fbdev/fbdev.c:770)

k = ioctl (priv->fd, FBIOGETCMAP, &cmap);

if (k < 0)
{
perror ("can't get colormap");
return;

FBIOGETCMAP is the ioctl to get the color map from the framebuffer driver.

comment:10 Changed 12 years ago by stefan@…

It seems I got to the root of all the problems. :)

During our meeting with mickey he talked about our theme and the 24bit artwork...

After disabling the theme and ignoring more hardcoded theme and artwork stuff it
looks like the 8bit mode worked fine all the time.

I tested this in the beginning but was confused from some hardcoded settings and
icons. At least I learned much abut the fb driver which I can use for the QVGA
support.

That means for 8bit we just need to change the swaping but have not useable UI
as we can not realize our theme in 8bit.

Harald, what was the reason for 8bit support? Just verify that the kernel driver
works fine, power saving or something else?

Dynamically switching between 8bit and 16bit with fbset should be possible but
is still has some problems and is under reseach for QVGA anyway.

comment:11 Changed 12 years ago by alphaone@…

So s3c2410fb 8bit mode is working.
Any progress on 1bit mode?

comment:12 Changed 11 years ago by olv@…

  • Owner changed from stefan@… to willie_chen@…

comment:13 Changed 11 years ago by willie_chen@…

  • Status changed from new to closed
  • Resolution set to fixed

No more problem here.

comment:14 Changed 2 years ago by Kennescoma

Mail Order Discount Cod Only Provera Medicine <a href=http://zol1.xyz/map.php>Zoloft Online Usa</a> Cytotec Udi Viagra Pfizer <a href=http://cial5mg.xyz/cialis.php>Cialis</a> Atopex Buy Generic Plavix Online India <a href=http://cial5mg.xyz/buy-generic-cialis-online.php>Buy Generic Cialis Online</a> Cialis En Generique We have rates that are lower than some banks. <a href=http://newcashloan356.com>quick loans</a> Payday loan products working paper PDF Kb.First time customers can borrow a fast cash loan of up to.Mygra 100 Mg Tablets <a href=http://zol1.xyz/can-i-buy-zoloft-online.php>Can I Buy Zoloft Online</a> Best Online Canadian Generics Pfizer Patient Assistance <a href=http://cial5mg.xyz/buy-cheap-cialis-site.php>Buy Cheap Cialis Site</a> Purchase Doxycycline Price Viagra En Suisse Sans Ordonnance <a href=http://cial5mg.xyz/buy-cheap-cialis-on-line.php>Buy Cheap Cialis On Line</a> Elocon 5g Delivered On Saturday Orlando Information About Priligy <a href=http://zol1.xyz/low-cost-zoloft-online.php>Low Cost Zoloft Online</a> Best Cheap Cialis Online Kamagra Farmacia A Buon Mercato <a href=http://cialis.ccrpdc.com/cialis-usa.php>Cialis Usa</a> Provera Get Low Price Metronidazole For Dogs No Rx <a href=http://zol1.xyz/best-zoloft-online.php>Best Zoloft Online</a> Cialis Generique Vrai Ou Faux Commande Cialis En France <a href=http://viag1.xyz/cheap-viagra-pill.php>Cheap Viagra Pill</a> Amoxicillin Maculopapular Virus Viagra Original 100mg <a href=http://kama1.xyz/kamagra-order.php>Kamagra Order</a> Zithromax Off Label Uses Get Macrobid Antibiotic <a href=http://kama1.xyz/buy-kamagra-oral-jelly.php>Buy Kamagra Oral Jelly</a> Commander Levitra Tadalafil Canadian Pharmacy <a href=http://zol1.xyz/sertralina-generic.php>Sertralina Generic</a> Cheap Suhagra Diflucan No Prescription <a href=http://cial5mg.xyz/cialis.php>Cialis</a> Opiniones Comprar Cialis Por Internet Commande Viagra Cialis <a href=http://cial5mg.xyz/buy-cialis.php>Buy Cialis</a> Cialis O Viagra Effetti Collaterali Cialis Ebay <a href=http://kama1.xyz/order-kamagra-pills.php>Order Kamagra Pills</a> Tadalafil Side Effects Vigra On Line <a href=http://doxycycline.ccrpdc.com/buy-vibramycin.php>Buy Vibramycin</a> Keflex What Is Lioresal Generique En France <a href=http://viag1.xyz/viagra-online-online.php>Viagra Online Online</a> Difference Between Cephalexin And Cephalexin Monohydrate Lioresal Prix <a href=http://strattera.ccrpdc.com/strattera.php>Strattera</a> Ou Acheter Cialis En Ligne Forum Cialis E Coumadin <a href=http://cial1.xyz/cheap-cialis-no-rx.php>Cheap Cialis No Rx</a> Comparaison Prix Cialis Buy Carafate Us <a href=http://zol1.xyz/order-generic-zoloft.php>Order Generic Zoloft</a> Cialis Online Drugstore Amoxicillin Ngu <a href=http://cial5mg.xyz/buy-cialis.php>Buy Cialis</a> Side Effects Of Amoxicillin For Macaw Levitra Eigenschaften <a href=http://antabuse.ccrpdc.com/by-cheap-antabuse.php>By Cheap Antabuse</a> Ordinare Viagra Generico Cialis Ventajas Y Desventajas <a href=http://zol1.xyz/cheap-zoloft-20mg.php>Cheap Zoloft 20mg</a> Comprare Viagra Ci Vuole La Ricetta Priligy Prescrizione Medica <a href=http://kama1.xyz/kamagra-online-fast.php>Kamagra Online Fast</a> Amoxicillin Clavulanic Acid 875mg 125mg Commander Cialis Prix Discount <a href=http://zol1.xyz/zoloft-online-usa.php>Zoloft Online Usa</a> Indian Pharmacy Viagra Precio Cialis 5 Mg 28 Comprimidos En Farmacias <a href=http://prozac.ccrpdc.com/buy-fluoxetine.php>Buy Fluoxetine</a> Zithromax For Tooth Abscess Viagra Mit Rezept Online <a href=http://lasix.ccrpdc.com/how-to-get-lasix.php>How To Get Lasix</a> Propecia How To Apply Amoxicillin 250 Gg 848 <a href=http://cial5mg.xyz/order-cialis-tablets.php>Order Cialis Tablets</a> Cialis Boite

Note: See TracTickets for help on using tickets.