Ticket #1945 (closed defect: duplicate)

Opened 9 years ago

Last modified 2 months ago

om2008.8: Sometimes I can't call my FreeRunner when it is in suspend (with logread/x.log/dmesg)

Reported by: dolfje Owned by: openmoko-devel
Priority: highest Milestone:
Component: unknown Version:
Severity: blocker Keywords: suspend om2008.8
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

If I put suspend mode on on the om 2008.8 distro, I (and others) sometimes can't call my FreeRunner?.

Steps for reproduce:

  1. put the software to suspend in 10sec
  2. Call my FreeRunner?
  3. if it succeed, leave it alone and let it suspend again
  4. wait for a couple minutes (sometimes 2 min, sometimes 30 min)
  5. goto step 2

Expected result:

  • You should be able to keep on calling the FreeRunner?.

Actual result:

  • The last time I called, it didn't resume on calling (around 10h03 ) and I get the voice mail on the other phone. I hang up and my FreeRunner? wakes up and says I've missed a phone call.

u-boot: 1.3.2-moko12 (http://downloads.openmoko.org/releases/Om2008.8-update/gta02v5_and_up-u-boot.bin)
kernel: http://downloads.openmoko.org/releases/Om2008.8-update/Om2008.8-gta02-20080826.uImage.bin
rootfs: http://downloads.openmoko.org/releases/Om2008.8-update/Om2008.8-gta02-20080830.rootfs.jffs2

dmesg, logread and x.log attached. (ps. The problem is around 10h03, then I've called it and it didn't resume)

reproducible: always, but sometimes it takes longer before it don't resume on phone-call.

Attachments

x.log (33.1 KB) - added by dolfje 9 years ago.
dmesg.output (15.2 KB) - added by dolfje 9 years ago.
logread.output (63.3 KB) - added by dolfje 9 years ago.

Change History

Changed 9 years ago by dolfje

Changed 9 years ago by dolfje

Changed 9 years ago by dolfje

comment:1 Changed 9 years ago by zecke

  • Owner changed from julian_chu to openmoko-devel
  • Component changed from Distro to unknown

Do not set a component. That is in http://wiki.openmoko.org/wiki/Bug_Filing_Policy.

comment:2 Changed 9 years ago by zecke

If you call the phone? Does it ring (where you call) or do you directly go to the mailbox

comment:3 Changed 9 years ago by dolfje

I goes directly into the mailbox.

What I also noticed:
If the phone isn't suspended, I get interference trough my computer speakers. So I can hear when the Neo FreeRunner? checks messages, gets connected, ...
If it goes into suspend, I don't get any interference trough my speakers anymore. So I think the modem somehow doesn't tell to the provider he's still there.

comment:4 Changed 9 years ago by self

The same problem here (GTA02),
uboot: factory
kernel: uImage-gta02-mwester-stable-d6f9fd270943fb22.bin
rootfs: qtopia-4.3.2-gta02-rootfs-release-08280107.jffs2 + 4.3.3 update

After a short time in suspend, I can call the mobile.

After a longer time (about 5 minutes), I hear "The number you dialed is currently not available". The freerunner does not seem to do anything, no missed call visible.

I've got a poor network reception, but this never was a problem, if the mobile is on. But maybe in suspend it's causing problems, in case this problem is not appearing for everybody?

comment:5 Changed 9 years ago by self

Provider is o2, Germany.

comment:6 Changed 9 years ago by zecke

  • Cc testing@… added

@self: a) You use the plain Qtopia, you might get more help at Trolltech for that.

b) The TI Calypso does not know that we are in suspend. And we have automatic call operator selection enabled. So even if the network is lost it should reconnect. For suspend we disabale network registration status messages (at least in our version of Qtopia).

@testing: Could you test this issue. Leave the device suspended for a while and give it a call, give it a call until you can connect and see how often you need to try that?

at the end of the day it is a TI Calypso issue... or something we don't yet understand about this chip.

comment:7 Changed 9 years ago by dolfje

I've updated today my stable om 2008.8 through opkg update, opkg upgrade and I can still (happily?) reproduce this bug. So If you need me to test something, just ask me. (mail: info#alasal,be)

comment:8 Changed 9 years ago by dolfje

I think this issue is related with #1662 and isn't related with suspend. Because I could reproduce this bug while the FreeRunner? wasn't in suspend. (see #1662)

comment:9 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to duplicate

If that's the case, I would mark this as duplicate of #1662.

comment:10 Changed 2 months ago by Chassmetly

Cialis Generique Pharmacie En Ligne <a href=http://lasix.ccrpdc.com/buy-lasix-without-rx.php>Buy Lasix Without Rx</a> Baclofen Pharm Support Group Canada <a href=http://viag1.xyz/sildenafil-generic.php>Sildenafil Generic</a> Viagra Durata Discount Elocon C.O.D. Can I Purchase With Free Shipping <a href=http://viagra.ccrpdc.com/sildenafil.php>Sildenafil</a> Illegal Cialis Doxycycline In Internet <a href=http://cial1.xyz/cialis-on-line.php>Cialis On Line</a> Pharmacy Escrow Refills Cialis Online Master Card <a href=http://antabuse.ccrpdc.com/buy-disulfiram-online.php>Buy Disulfiram Online</a> Acquistare Cialis San Marino Cialis Achat Internet Forum <a href=http://zol1.xyz/zoloft-prices.php>Zoloft Prices</a> Priligy Company Viagra Rouge <a href=http://kama1.xyz/cheapest-kamagra.php>Cheapest Kamagra</a> Acheter Cialis Bordeaux Viagra Vente Libre Pays <a href=http://cial1.xyz/buy-cheap-cialis-on-line.php>Buy Cheap Cialis On Line</a> Compra Propecia Amoxicillin Dosages <a href=http://zol1.xyz/implicane.php>Implicane</a> Quand Prendre Le Cialis Cialis Pas Cher Levitra <a href=http://cytotec.ccrpdc.com/how-to-order-cytotec.php>How To Order Cytotec</a> Amoxicillin Treatment Of Chlamydia Viagra Effets Immediats <a href=http://cial5mg.xyz/buy-cialis.php>Buy Cialis</a> Is It Illegal To Buy Lasix Online Cialis O Levitra Cual Es Mejor <a href=http://viag1.xyz/sildenafil-100mg.php>Sildenafil 100mg</a> Cialis Overnight Fedex Cephalexin 500 While Im Breastfeeding <a href=http://xenical.ccrpdc.com/orlistat-price.php>Orlistat Price</a> Cialis Rezept Falschen Buy Isotretinoin Without Perscription <a href=http://cial5mg.xyz/ordering-cialis-online.php>Ordering Cialis Online</a> Where Can I Buy Generic Provera Best Website Propecia Shelf Life <a href=http://zol1.xyz/purchase-zoloft.php>Purchase Zoloft</a> Nombre Droga Generica Viagra Cialis 20 Mg Prezzo <a href=http://kama1.xyz/buy-kamagra-online-100mg.php>Buy Kamagra Online 100mg</a> Worldwide Amoxicilina Antibiotic For Sale Discount With Overnight Delivery Propecia Pisos <a href=http://zol1.xyz/cheapest-zoloft.php>Cheapest Zoloft</a> Cialis Non Generic Alcool Levitra Generico <a href=http://cial1.xyz/cialis-40mg.php>Cialis 40mg</a> Clomid Apport D Aide Baclofen Tablet <a href=http://viag1.xyz/sildenafil-citrate.php>Sildenafil Citrate</a> Misoprostol Online Fast Shipping Controindicazioni Per Il Cialis <a href=http://cial5mg.xyz/tadalafil-20mg.php>Tadalafil 20mg</a> Cialis Buy Eu Cialis Original De La India <a href=http://clomid.ccrpdc.com/buying-clomid-online.php>Buying Clomid Online</a> Buy Acyclovir Cream Over The Counter Viagra Kaufen Cialis Online Bestellen <a href=http://cial5mg.xyz/cialis-online.php>Cialis Online</a> Cialis Kaufen Berlin Cephalexin Kidney In Cats <a href=http://cial1.xyz/buy-cialis-cheap.php>Buy Cialis Cheap</a> Propecia Prix Pas Cher Cialis 5mg 28 St <a href=http://zol1.xyz/buy-online-zoloft.php>Buy Online Zoloft</a> Soft Tab Cialis Cheap Nexium <a href=http://viag1.xyz/sildenafil-generic.php>Sildenafil Generic</a> Drugs Similar To Cephalexin Shelf Life Cephalexin <a href=http://kama1.xyz/cheap-kamagra.php>Cheap Kamagra</a> Commande De Cialis En France Relajarse Propecia <a href=http://zol1.xyz/generic-zoloft-usa.php>Generic Zoloft Usa</a> Topamax And Propecia No Prescription Tadalafil <a href=http://zol1.xyz/order-zoloft.php>Order Zoloft</a> Cytotec Vaginal El Cialis Sirve Para La Mujer <a href=http://kama1.xyz/kamagra-tablet.php>Kamagra Tablet</a> Secure ordering isotretinoin isotrex tab Buy Cialis In Dubai <a href=http://cial1.xyz/cialis-generic.php>Cialis Generic</a> Cialis 20mg De Cialias Online Over Night Delivery <a href=http://doxycycline.ccrpdc.com/buy-cheap-vibramycin.php>Buy Cheap Vibramycin</a> Prix Kamagra Achat Amoxicillin Pharmacie A Bon Compte France <a href=http://kamagra.ccrpdc.com/cheapest-kamagra.php>Cheapest Kamagra</a> Side Effects Of Kamagra Ph Of Amoxicillin <a href=http://cial5mg.xyz/cialis-price.php>Cialis Price</a> Online Cialis Without A Prescription Canadien Farmacy Viagra Super Active <a href=http://cial5mg.xyz/cialis-online.php>Cialis Online</a> Medecine Misoprostol Acheter Baclofene Sur Internet <a href=http://cial5mg.xyz/buy-cheap-cialis.php>Buy Cheap Cialis</a> Buy Tadalista Where To Buy Penicillin Vk Online? <a href=http://cial1.xyz/cialis.php>Cialis</a> Acheter Du Baclofen Shipped Ups Amoxicilina Amoxin Shop <a href=http://kama1.xyz/where-to-order-kamagra.php>Where To Order Kamagra</a> Orlistat 60 For Sale Ist Levitra Rezeptpflichtig <a href=http://cial5mg.xyz/how-to-order-cialis.php>How To Order Cialis</a> Aid Achat Cialis Meilleur Prix <a href=http://kama1.xyz/kamagra-forum.php>Kamagra Forum</a> How To Order Roaccutane In The Usa Cialis Agit En Combien De Temps <a href=http://cial1.xyz/purchase-cialis.php>Purchase Cialis</a> Immune To Amoxicillin Buy Antabuse Disulfiram <a href=http://viag1.xyz/purchase-viagra.php>Purchase Viagra</a> Generic Viagra Soft Tabs 50mg Pastillas Para La Ereccion Masculina <a href=http://cial5mg.xyz/order-cialis-online-usa.php>Order Cialis Online Usa</a> Suprax 400mg For Sale

Note: See TracTickets for help on using tickets.