Ticket #195 (closed enhancement: fixed)

Opened 12 years ago

Last modified 2 years ago

passthrough mode (Directly use GSM Modem from PC

Reported by: laforge@… Owned by: laforge@…
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: minor Keywords:
Cc: mickey@…, sean_mosko@…, buglog@…, jserv@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

In order to make it easy to do gsmd/libgsmd/dialer development on the host PC,
we want something called the 'gsm passthrough mode'.

This basically means that on the host PC, we want to see a virtual serial port
via USB (CDC ACM, /dev/ttyACM0). If a host application talks to that virtual
serial port, it actually talks directly to the GSM Modem.

So what needs to be done, is extend u-boot by a piece of code, which

1) powers up the GSM Modem
2) de-asserts GSM_EN (0) to connect GSM Modem to S3C2410
3) listens to USB control endpoint packets to configure baudrate/... of
GSM-facing S3C2410 UART
4) send incoming characters from UART to USB IN endpoint according to CDC ACM spec
5) send incoming charcters from USB OUT endpoint to UART according to CDC ACM spec

This whole software module is part of u-boot and shall be activated by issuing a
command "neo1973 gsm passthrough" at the u-boot command prompt.

Change History

comment:1 Changed 12 years ago by laforge@…

I'm not entirely sure if u-boot is really the right location to do this.

Having it in u-boot would make sure that there is no conflict between native
phone gsmd (plus higher level apps) and the passthrough/host access.

Heving it in userspace on linux would mean that the phone could still be used as
a PDA. Also, an userspace implementation could probably even be accessed via
Bluetooth at some later point. Plus it could be extended to just give access to
one of the demultiplexed DLC's, 'sharing' the phone.

Also, having it not in u-boot means we don't need to do a u-boot update (which
is critical).

comment:2 Changed 12 years ago by laforge@…

  • Owner changed from laforge@… to stefan@…
  • Milestone set to Phase 1

comment:3 Changed 12 years ago by laforge@…

* Bug 105 has been marked as a duplicate of this bug. *

comment:4 Changed 12 years ago by werner@…

We probably wouldn't want to have to reboot the phone just to use it to
check our mail from a USB-attached notebook anyway. So one more vote
against doing this in u-boot.

comment:5 Changed 12 years ago by stefan@…

I send a request for comments to the usb-devel mailling list for extending the
g_serial driver to our needs:

http://marc.theaimsgroup.com/?l=linux-usb-devel&m=117339471429600&w=2

comment:6 Changed 12 years ago by jluebbe@…

  • Owner changed from stefan@… to laforge@…

comment:7 Changed 12 years ago by alphaone@…

  • Severity changed from normal to enhancement

Any news on this topic? Is this still an issue for phase 1?

comment:8 Changed 12 years ago by laforge@…

  • Cc mickey@… added

* Bug 464 has been marked as a duplicate of this bug. *

comment:9 Changed 12 years ago by jserv@…

  • Cc jserv.tw@… added

comment:10 Changed 12 years ago by laforge@…

  • Status changed from new to closed
  • Resolution set to fixed

this has been implemented as of svn rev. 2885.

comment:11 Changed 11 years ago by anonymous

  • Milestone Phase 1 deleted

Milestone Phase 1 deleted

comment:12 Changed 2 years ago by JustDox

Finax For Sale <a href=http://viag1.xyz/viagra-online-fast.php>Viagra Online Fast</a> Cialis Mail Order Same Day Delivery Candain Drug <a href=http://viag1.xyz/how-much-is-viagra.php>How Much Is Viagra</a> Tadalafil Online Canadian Pharmacy Amoxicillin A 45 Picture <a href=http://cial5mg.xyz/female-cialis.php>Female Cialis</a> Baclofene Rembourse Kamagra Naturale <a href=http://kamagra.ccrpdc.com/kamagra-buy-online.php>Kamagra Buy Online</a> Propecia Shedding To Work Acheter Cialis 5 Mg Comprime Pellicule Boite De 28 <a href=http://viag1.xyz/price-generic-viagra.php>Price Generic Viagra</a> Cheapest Us Pharmacy For Viagra Cheap Cialis Super Active <a href=http://cial5mg.xyz/cialis.php>Cialis</a> Buy Cheap Cialis Online Viagra Ausprobieren <a href=http://zol1.xyz/cheap-zoloft-no-rx.php>Cheap Zoloft No Rx</a> Sin Receta Comprar Propecia Amoxicillin Allergic Reactions For Dogs <a href=http://cial5mg.xyz/cheap-cialis-online.php>Cheap Cialis Online</a> Propecia En Prostata Levitra Lakemedel <a href=http://kama1.xyz/buy-generic-kamagra.php>Buy Generic Kamagra</a> El Cialis Funciona Mejor Que El Viagra 3g Amoxicillin Oral Dose <a href=http://cytotec.ccrpdc.com/misoprostol-cytotec.php>Misoprostol Cytotec</a> Lasix For Dog Without Prescription Ou Acheter Kamagra A Montreal <a href=http://viag1.xyz/how-to-get-viagra.php>How To Get Viagra</a> Levitra Sotto Lingua Prezzo Medio Kamagra <a href=http://zol1.xyz/buy-cheap-generic-zoloft.php>Buy Cheap Generic Zoloft</a> buy Female Viagra Levitra Para Diabeticos <a href=http://kama1.xyz/purchase-generic-kamagra.php>Purchase Generic Kamagra</a> Prix Propecia Officiel Viagra Haltbarkeit <a href=http://viag1.xyz/best-viagra-online.php>Best Viagra Online</a> Best Price Cailis Effects Of Homeopathic Amoxicillin On Pets <a href=http://cial1.xyz/cheapest-cialis.php>Cheapest Cialis</a> Discount Worldwide On Line Elocon Medicine Secure Ordering Posologie Viagra 25mg <a href=http://strattera.ccrpdc.com/strattera-online-usa.php>Strattera Online Usa</a> Peritol Cyproheptadine Buy Kamagra Jelly <a href=http://cial5mg.xyz/cheap-cialis-40mg.php>Cheap Cialis 40mg</a> Propecia 12 Weeks Where To Buy Generic Flagyl Online Without Prescription <a href=http://cial5mg.xyz/tadalafil-20mg.php>Tadalafil 20mg</a> Urologia Priligy Buy Tretinoin Online <a href=http://kama1.xyz/kamagra-cheap.php>Kamagra Cheap</a> Pastilla Cialis Can I Order Valtrex Online <a href=http://cial1.xyz/buying-cialis-online.php>Buying Cialis Online</a> Amoxicillin And Iron Amoxicillin For Sale Canada <a href=http://kamagra.ccrpdc.com/kamagra-gel-online.php>Kamagra Gel Online</a> Levaquin 500mg Cephalexin 500mg Price For A 100 Mg Viagra <a href=http://cial5mg.xyz/tadalafil-online.php>Tadalafil Online</a> Stendra Buy Best Website Pharmacie Online Viagra Discount <a href=http://zoloft.ccrpdc.com/zoloft-online.php>Zoloft Online</a> Propecia Equidad Buy Kamagra Donne <a href=http://cial1.xyz/buy-tadalafil-online.php>Buy Tadalafil Online</a> Kamagra Gel France Cialis Efectos A Largo Plazo <a href=http://viag1.xyz/where-to-buy-viagra.php>Where To Buy Viagra</a> Amoxicillin Alcohol Interaction Price On Cialis 5mg No Prescription <a href=http://kama1.xyz/order-kamagra-tablets.php>Order Kamagra Tablets</a> Cialis Lilly Pharma Intolerance Amoxil <a href=http://inderal.ccrpdc.com/low-price-inderal.php>Low Price Inderal</a> Baclofene Mylan Domperidone 10 Mg New Zealand <a href=http://kama1.xyz/buy-kamagra-online-100mg.php>Buy Kamagra Online 100mg</a> Want To Buy Fluoxetine Panic Attacks Venta Cialis Tenerife <a href=http://cial5mg.xyz/prices-cialis.php>Prices Cialis</a> Levitra Farmacia Acquisto Rezeptfrei Viagra Ausland <a href=http://viag1.xyz/viagra-samples.php>Viagra Samples</a> Generika Cialis De Efectos De La Viagra En Jovenes <a href=http://cial5mg.xyz/generic-cialis-online.php>Generic Cialis Online</a> Amoxicillin Buy Misoprostol Prix Canada <a href=http://cial1.xyz/cialis-cheap.php>Cialis Cheap</a> Acheter Du Cialis En Toute Legalite a. <a href=http://newcashloan356.com>short term loans</a> total cost of credit.I like the way they work because they are flexible and try their best to help.Propecia 100mg <a href=http://zol1.xyz/order-zoloft-tablets.php>Order Zoloft Tablets</a> Clomid 25 Otc Priligy Or Viagra <a href=http://kama1.xyz/kamagra.php>Kamagra</a> Propecia Epilobio Precio Amoxicillin And Death In Cats <a href=http://priligy.ccrpdc.com/priligy-30mg-price.php>Priligy 30mg Price</a> El Cialis No Me Hace Efecto Cheap Silagra Uk <a href=http://zol1.xyz/zoloft-prices.php>Zoloft Prices</a> Achat Cialis Inde

Note: See TracTickets for help on using tickets.