Ticket #1950 (closed enhancement: fixed)

Opened 11 years ago

Last modified 11 years ago

[Installer] system update packages

Reported by: wendy_hung Owned by: tick
Priority: normal Milestone: Om2008.10
Component: Distro Version:
Severity: major Keywords: Updating Packages
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Hi Tick!
I hear that we will now have all system packages in one single package called 'System Update' so I created a ticket for you. Please let us know the progress so we can start testing.

Thanks :)

Change History

comment:1 Changed 11 years ago by tick

  • Status changed from new to accepted

comment:2 Changed 11 years ago by tick

  • Component changed from Installer to Distro
  • Severity changed from blocker to major
  • Milestone Om2008.9 deleted

This need to be done after release.
Every package will be different, and need to be tested.

I will think about how to create such stuff.

Before this, we need to clean up our OM.dev.
I think it more distro issue, and may become a routine job.
So I remove the Milestone, change the Component, and Severity.
After Installer can accept this kind of package.
I will then close this ticket.

If there has any new such package, I will info testing Team.

comment:3 Changed 11 years ago by wendy_hung

  • Milestone set to Om2008.9

comment:4 Changed 11 years ago by tick

Hi Will,

After think for a while, I think create a fake package in Installer (a button) called system-update or update-all , in which actually do the opkg upgrade, is good enough for our needs.

Why?

Because the package in our repository shall be tested already. They shall good enough to do the opkg upgrade.
This way we won't have provide extra effort to maintain another list of updated packages. It's much more simple, automatically, and less effort.

Therefore, I will turning this ticket as "creating a update-all button".

Cheers,
Tick

comment:5 Changed 11 years ago by tick

  • Status changed from accepted to in_testing

Done at assassin svn 244

comment:6 Changed 11 years ago by will

  • Milestone changed from Om2008.9 to Om2008.10

comment:7 Changed 11 years ago by tick

  • Status changed from in_testing to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.