Ticket #1956 (closed defect: community)

Opened 6 years ago

Last modified 5 years ago

Mediaplayer2 audio quality

Reported by: Zoup Owned by: openmoko-devel
Priority: highest Milestone: Om2007.2
Component: unknown Version: Om2007.2
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Audio quality of mediaplayer2 is Crap which mplayer perform much better quality .

Change History

comment:1 Changed 6 years ago by TimoJyrinki

You should be much more specific in your bug report. Suggesting closing if no details are provided.

I'm using mediaplayer2 and playing mp3:s and ogg:s without problems. I'm using mixer settings that are described in the wiki to balance low frequencies and have set the main volume from 100 to ca. 95. Audio quality is sufficient for my uses (in car via an adapter etc.).

comment:2 Changed 6 years ago by Zoup

well , i thought the issue is very clear to everyone thats why i didn't specified much detail .
if you believe that this issue is with mixer setting , simple question would be 'why mplayorking great' , its clearly is mediaplayer2 issue and i believe this bug report is necessary .

i did exactly followed the wiki as well , but still i hear lots of Noise and noisy echoes of music , i can hear more of them when using Headsets .

comment:3 Changed 6 years ago by rutgerbazen

I have this problem as well.
Here are my findings:

The sound quality of mediaplayer2 was very poor.
This was caused by the volume of mediaplayer2.
After turning down the volume in mediaplayer2 to about 7%, the quality was very acceptable.
I tried to put the volume of mediaplayer2 to 50% and edit the alsa volumes using alsamixer.
This did not give any audio quality improvements.

So:

mediaplayer2 volume: ~7% - good quality

I hope this helps.

comment:4 Changed 6 years ago by rutgerbazen

Forgot to mention. I use Om2008.9

comment:5 Changed 5 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community

I don't think we will keep maintaining mediaplayer2 so closed as community.

Note: See TracTickets for help on using tickets.