Ticket #197 (closed defect: community)

Opened 11 years ago

Last modified 9 years ago

Make theme suitable for qvga screens.

Reported by: stefan@… Owned by: michael
Priority: high Milestone:
Component: Theming - Gtk+ Version: unspecified
Severity: normal Keywords:
Cc: mickey@…, buglog@…, koen@…, philipp.zabel@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Many phones have qvga screens only (HTC, EZX,..). We need a way to deal with this.

Some first thoughts about the problem:

  • Create a qvga theme.
  • Adjust settings in gtkrc. Philipp Zabel already started this.
  • All images for the theme needs rescaling. We can start with some convert magic

here, but on long term we need official pixmaps even for qvga.

What else is needed?

Attachments

gtkrc-qvga.patch (24.5 KB) - added by stefan@… 10 years ago.
gtkrc qvga patch from Philipp Zabel
openmoko-standard-qvga.tar.gz (175.9 KB) - added by philipp.zabel@… 10 years ago.
openmoko-standard theme downscaled
openmoko-theme-standard-qvga2.diff (25.0 KB) - added by philipp.zabel@… 10 years ago.
first shot at scaling down the openmoko-standard gtk and matchbox theme

Change History

comment:1 Changed 11 years ago by stefan@…

  • attachments.description changed from gtkrc qvga patch to gtkrc qvga patch from Philipp Zabel

comment:2 Changed 11 years ago by stefan@…

(From update of attachment 9)
gtkrc qvga patch from Philipp Zabel

comment:3 Changed 11 years ago by koen@…

  • Cc koen@… added

comment:4 Changed 11 years ago by koen@…

It seems that the patch just halves the values, is it possible to do that at
runtime by detecting screen size and dpi (or machine type).

comment:5 Changed 11 years ago by mickey@…

I'll gladly accept patches to add a openmoko-theme-qvga + corresponding images.
I think it should live in the official repository, not as a project. For now,
(offline) rescaling the images will do, but eventually I hope we can get the
"official" designer to provide qvga images as well. Not soon though.

comment:6 Changed 11 years ago by mickey@…

  • Status changed from new to assigned

Thanks, I have assigned that to me and will include it in SVN right after FOSDEM.

comment:7 Changed 11 years ago by koen@…

  • Owner changed from ken_zhao@… to mickey@…
  • Status changed from assigned to new

comment:8 Changed 11 years ago by laforge@…

  • Cc mickey@… added
  • Owner changed from mickey@… to sean_mosko@…

Mickey: Can you please integrate it now, since FOSDEM is over?

Sean:

Mickey and I have agreed that if the graphics designers are currently mostly
idle, then we should ask them to provide a QVGA version of all the pixmaps they
have done so far. For all future deliverables from the graphics designers, they
should always provide one VGA and one QVGA version.

comment:9 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

applied in r1531 - thanks!

comment:10 Changed 10 years ago by philipp.zabel@…

  • Cc philipp.zabel@… added
  • Status changed from closed to reopened
  • Resolution fixed deleted

New theme, new problems. openmoko-theme-standard2 needs to be QVGAified. Also,
QVGA screens don't work too well with 36x36 stock icons - I guess
openmoko-icon-theme-standard2 has to be modified, too.
And then there are images which are used unscaled all over the place. For
example all the openmoko-panel applets (except the startup-notification applet,
that one seems to scale already) and the images used in openmoko-dialer2.

Changed 10 years ago by philipp.zabel@…

openmoko-standard theme downscaled

Changed 10 years ago by stefan@…

gtkrc qvga patch from Philipp Zabel

comment:11 Changed 10 years ago by philipp.zabel@…

  • attachments.isobsolete changed from 0 to 1

comment:12 Changed 10 years ago by philipp.zabel@…

  • attachments.isobsolete changed from 0 to 1

comment:13 Changed 10 years ago by mickey@…

attached and commited, thanks Philipp. Leaving this open since there is still
some work to do wrt. stock icons and also wrt. matchbox-panel-2 which obviously
has a race condition when dealing with scaled images. We might be able to
workaround that in libmokopanelui2.

comment:14 Changed 10 years ago by philipp.zabel@…

I'd propose to make the stock icons 22x22 for the QVGA theme. That way they'll
still end up a bit bigger on 2.8" and 2.6" QVGA, but it is a standard size on
the desktop and 16x16 is really a bit limiting.

comment:15 Changed 10 years ago by mickey@…

any outstanding issues or can we close this now?

comment:16 Changed 10 years ago by philipp.zabel@…

The issues with the GTK theme itself are solved AFAIK. The icon theme
downscaling in OpenEmbedded? is kind of a hack - I think this should be handled
upstream.

Then, there are some applications (Dialer!) that provide their own icons instead
of using stock icons, and those have yet to be rescaled separately or moved into
the moko icon theme. One could argue that this is out of the scope of this bug
and that these issues should be filed separately.

comment:17 Changed 10 years ago by koen@…

The qvga theme lacks gtkrc files for e.g. mokomediaplayer

comment:18 Changed 10 years ago by olv@…

  • Status changed from reopened to closed
  • Resolution set to later

let's not worry about this

comment:19 Changed 10 years ago by mickey@…

  • Status changed from closed to reopened
  • Resolution later deleted

I disagree, we should worry about this. There are tons of QVGA devices out there
and if we close this, then it looks like we don't care about OpenMoko? being used
on non-FIC devices. We surely don't want to give this message, right?

comment:20 Changed 10 years ago by mickey@…

  • Status changed from reopened to new
  • Owner changed from sean_mosko@… to michael@…

Reassigning to Michael, since this is a "community" bug.

comment:21 Changed 9 years ago by roh

  • Owner changed from michael@… to michael

comment:22 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.