Ticket #1974 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Enlightenment is slow to start / restart / update

Reported by: Treviño Owned by: raster
Priority: normal Milestone:
Component: E - Illume Version: Om2008.8
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

I've installed the Rasterman Image weeks ago, then I've updated it (but holding the illume package) using the zecke feeds and now I'm using only the Om2008.8 repository.
So now I'm running e-wm 0.16.999.043+svnr35818-r12 and illume 0.0+svnr215-r8.

However until the 0.16.999.043+svnr35727-r12 update (two updates ago), Enlightenment loaded well and I was able to restart it quickly; it was quick to update itself when I was updating a desktop file too. I've also some slowdowns while I'm loading an application (I get the loading screen and after few seconds it hangs for some seconds, until I get the application in my screen).

Now, instead, Enlightenment takes about 3-5 minutes to load, a little less to reload, and about a minute to update the desktop on changes.

Also if I didn't installed so many more apps since when E was working well, I've noticed that if I move all the /usr/share/applications/*.desktop in a temporary location E loads quickly and any other issue reported seems to disappear.
I thought that this could have been due to a bad formatted desktop file, but also re-adding them one per time I can't find the problem.
So I'm attaching here my desktop files (they're concatenated in a file).

Another thing I lost updating E is that I can't configure anymore is the Finger scrolling from the illume config, but this is another bug report :P

PS: removing my ~/.e configuration doesn't solve too!

Attachments

om2008-desktop-files.list (19.3 KB) - added by Treviño 11 years ago.
My /usr/share/applications/*.desktop files

Change History

Changed 11 years ago by Treviño

My /usr/share/applications/*.desktop files

comment:1 Changed 11 years ago by Treviño

Ops trac made for me two tickets... Please remove the #1973!

comment:2 Changed 11 years ago by raster

i can't say. might be the fact that illume is old and based off the old projects.om.org tree that isn't being maintained anymore (it's moved to enlightenment.org's svn tree). i put all your .desktop files on my FSO build and even added icons for all - and well. e starts up no slower than normal really (well it takes a little longer to scan .desktop build the app view and then refresh - but a few seconds at most).

i'm not sure what's up over in 2008.08/09/asu land but as such my FSO build of e/illume (a little newer - 0.16.999.043+svnr35888-r11) is marching along happily as i'd expect. i can't reproduce here on "current" code (i'm not going to roll back to the versions you have as whatever the problem is - i can assume is gone or is some problem related to the combo being used etc.), but it doesn't exist right now

comment:3 Changed 11 years ago by Treviño

Ok, I've updated the illume packages (well I didn't before since I was worried by the idea of losing your keyboard), but I was wrong.
Now illume loads correctly in few seconds so this is all a my fault and I figure that you can close this bug as invalid :P

PS: just two OT things:

  1. Isn't there a way to override a system keyboard adding one with the same name in userspace?
  2. Is there a possibility to get the desktop icons scroll smooth as it is in the configuration or in the words list? I hope you could do some optimizations (well using an iphone-like style [that I don't like too much] maybe could be a workaround?)

comment:4 Changed 11 years ago by raster

  • Status changed from new to closed
  • Resolution set to fixed

1)

  1. keyboards are pluggable (if it's 3rd party keyboard apps that you mean) and illume has a gui config to select what one to run (or use illume's built-in). just need "Keyboard" in the Categories list for the .desktop for the kbd to run.
  2. if you mean personal .kbd layout files - yes. put your personal Default.kbd, Numbers.kbd ... or anything else in ~/.e/e/keyboards/ and it will take preference over the system package installed one :) same for ~/.e/e/dicts/ :)

2)
scrolling is done the exact same way in both situations - objects are moved around and thus the areas that change are redrawn (as things are moving over a static background with alpha a redraw is required). the difference is that the icons are well just more complex to draw, more things to draw. more work - thus slower to update. a combination of memory bandwidth and cpu in general as wel as the glamo has made this way of doing things really not work as well as it does on many other embedded platforms (the n800 does this much more smoothly - even at 300mhz for example). even my ancient zaurus sl-c860 (i bought (400mhz xscale with an ati imageon @ 640x480) does better (visibly...) and that came out about 4 years ago. in general the FR is particularly poor with being able to do redraws where every "embedded system" i have used and coded for and ported/run evas stuff on (zaurus sl5500/sl-c860, ipaq 3660, nokia n800, and other prototype hardware not released) has coped amazingly well. generally the "redraw it all using the cpu" works almost as well as accelerated blitting - if the platform has it, or well. enough, but the bonuses of having alpha blending, layers etc. are worth the swap. :) on the FR this equation has not come to be true. the fact is that trying to use hardware blit will be tricky as it totally bypasses the rendering pipeline and will limit you to a ui style that in all other places is possible and easy to do, so making the FR an exception to the rule.

so as such. nothing to be done. well not without impacting development for many other devices. if it were me i'd not have scrolling. i'd paginate the display and you flip pages, not scroll. iphone-style still scrolls as such, but i don't intend to really address this stuff - i'm currently quite busy :(

comment:5 Changed 11 years ago by Treviño

Ok, I've understood. :/
Thanks for your exhaustive replies anyway! :)
However using the default theme performs better than using the tango ones...

comment:6 Changed 11 years ago by Treviño

Ah, I forgot to mention another thing (well, again more OT), but I've put more than 50 System menu entries (desktop files with an icon to be shown in the Illume configuration) and there the finger scroll was smoother... BTW I know that there are shown less icons than in the desktop itself.

It looked like this: http://scap.linuxtogo.org/files/000dc950aa7160806b4549bd711aa1e2.png

Note: See TracTickets for help on using tickets.