Ticket #1982 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[Location] the last line of tag will only show up half

Reported by: wendy_hung Owned by: tick
Priority: normal Milestone: Om2008.10
Component: Locations Version:
Severity: normal Keywords:
Cc: testing@…, olv@…, marek@…, tick@…, jeremy@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

Summary:
the last line of tag will only show up half

kernel:Om2008.8-gta02-20080903.uImage.bin
root file system:Om2008.8-gta02-20080908.rootfs.jffs2

Steps+current results:
1) launch Location which has more than 10 tags
2) check the list
3) the last tag will only show up half and it's hard to touch it

Expected:
show up complete tag

Attachments

Screenshot-1.png (34.7 KB) - added by wendy_hung 11 years ago.
01_adding_scrolled_view_margins.patch (6.2 KB) - added by tick 11 years ago.
adding optional margins for scrolled_view
02_break_the_jail_of_none_scrolled_view_with_margins.patch (1.0 KB) - added by tick 11 years ago.
Fix the known issue of first patch(remove unnecessary check)
03_remove_half_done_function_pointer.patch (2.0 KB) - added by tick 11 years ago.
(Optional) remove half done function about margin
etk_scrolled_view_adding_scrolled_view_margins.patch (10.0 KB) - added by tick 11 years ago.
updated patch

Change History

Changed 11 years ago by wendy_hung

comment:1 Changed 11 years ago by will

  • Cc marek@… added

marek,
remember how you solved this for exposure?

comment:2 Changed 11 years ago by marek

Sure - add any empty unclickable last item. It is not that beautiful but will do the job.

comment:3 Changed 11 years ago by jeremy

  • Status changed from new to accepted

comment:4 Changed 11 years ago by tick

  • Cc tick@… added

Hi Jeremy,
I will deal with the etk park, after that I will info you.

comment:5 Changed 11 years ago by tick

  • Owner changed from jeremy to tick

Changed 11 years ago by tick

adding optional margins for scrolled_view

Changed 11 years ago by tick

Fix the known issue of first patch(remove unnecessary check)

Changed 11 years ago by tick

(Optional) remove half done function about margin

comment:6 Changed 11 years ago by tick

  • Cc jeremy@… added

Hi Jeremy,

I created three patches that. The first two patch can help you set the extra margin for a scrolled_view. I think these two patches can help us solving this issue.

adding four new API
void etk_scrolled_view_extra_vmargin_set(Etk_Scrolled_View *scrolled_view, int margin);
int etk_scrolled_view_extra_vmargin_get(Etk_Scrolled_View *scrolled_view);
void etk_scrolled_view_extra_hmargin_set(Etk_Scrolled_View *scrolled_view, int margin);
int etk_scrolled_view_extra_hmargin_get(Etk_Scrolled_View *scrolled_view);

Demo code:
diff --git a/etk/src/bin/etk_scrolled_view_test.c b/etk/src/bin/etk_scrolled_view_test.c
index bc3650f..c0d7007 100644
--- a/etk/src/bin/etk_scrolled_view_test.c
+++ b/etk/src/bin/etk_scrolled_view_test.c
@@ -46,6 +46,7 @@ void etk_test_scrolled_view_window_create(void *data)

scrolled_view = etk_scrolled_view_new();
etk_scrolled_view_dragable_set(ETK_SCROLLED_VIEW(scrolled_view), 1);

+ etk_scrolled_view_extra_vmargin_set(ETK_SCROLLED_VIEW(scrolled_view), 60);

etk_container_add(ETK_CONTAINER(win), scrolled_view);


canvas = etk_canvas_new();

I will apply first two patches on OM.dev first. After writing more comments, adding properties, I will send to them upstream.
Hope will be applied. :-P

For python binding, because it adds new API, so that that part should be added to pxd and pxi files. (maybe after applied to upstream)

Cheers,
Tick

Changed 11 years ago by tick

updated patch

comment:7 Changed 11 years ago by tick

merge patch 1 & 2.
solving some miscount issues
adding some comments
indent the coding style for etk

Jeremy,

You may take a trial.

comment:8 Changed 11 years ago by tick

  • Status changed from accepted to in_testing

comment:9 Changed 11 years ago by will

  • Version Om2008.8 deleted
  • Milestone changed from Om2008.9 to Om2008.10

comment:10 Changed 11 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

kernel : 20080903
rootfs : 20080924
it has fixed.

Note: See TracTickets for help on using tickets.