Ticket #1985 (closed defect: invalid)

Opened 11 years ago

Last modified 10 years ago

no auto-suspend after some time

Reported by: h.koenig Owned by: jeremy
Priority: normal Milestone:
Component: kernel Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: #1991 Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Om 20008.8 + updates: since the last 1 or 2 updates (maybe up to a week now ?!) I notice that auto-suspend doesn't work anymore for me.

I've set "blank screen" and "suspend after blank" both to 60 seconds but after a while either only screen blank works, or even neither screen blanker nor suspend work. (it's ok just after fresh boot).

right now when pressing the power button, only screen blanker gets activated, no suspend -- but "apm -s" from ssh login still suspends,
so it's not the "device or resource busy" issue...

3 ideas what might trigger this problems:

a) it's triggered by my atd job which rus every 10 minutes to log battery data. if that atd job resumes the suspended FR, then there will be no new auto-blank or auto-suspennd anymore.

b) it's triggered by pressing the power button to suspend

c) the phone is kept alive because of lots of GSM communication I can see in "logread" output:

logread | grep simyo

Sep 10 12:43:36 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:43:37 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:45:09 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:45:09 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:46:10 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:46:10 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:46:50 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:46:51 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:46:51 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:47:55 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:47:56 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:48:38 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:48:38 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:49:27 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:49:42 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:51:38 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:51:38 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:52:20 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:52:20 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:52:20 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:53:01 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:53:02 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:53:49 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:53:50 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:54:30 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:54:30 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:55:20 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""
Sep 10 12:55:45 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"simyo""

root@om-gta02:~# opkg list_installed kernel
kernel - 2:2.6.24+git75969+a1e97c611253511ffc2d8c45e3e6d6894fa03fa3-r1.01 -

which other information do you need ?

what can I trace to figure out

  • why suspend doesn't work anymore (what happens when pressing power button)
  • what triggers that problem...

thanks for pointers!

Change History

comment:1 Changed 10 years ago by john_lee

  • Owner changed from openmoko-devel to jeremy
  • Status changed from new to assigned
  • HasPatchForReview unset
  • Component changed from unknown to System Software

I believe julian is also seeing this on his phone. jeremy, could you help looking into this?

comment:2 Changed 10 years ago by john_lee

  • Blocking 1991 added

(In #1991) I will add similiar bugs here so it's easier to track.

comment:3 Changed 10 years ago by PaulFertser

  • Status changed from assigned to closed
  • Resolution set to invalid

Looks like qpe issue. Please use a supported distro instead.

Note: See TracTickets for help on using tickets.