Ticket #1986 (closed defect: wontfix)

Opened 11 years ago

Last modified 10 years ago

AUX LED blicks too early at power on

Reported by: h.koenig Owned by: andy
Priority: normal Milestone:
Component: kernel Version:
Severity: normal Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

when booting the FR with 8-second-pwr-button the AUX LED flashes too early, because this often triggers me to release the pwr button ("hey, it's alive") which is just too early for startup -- the FR won't start and I have to press pwr for another 8 seconds (and close my eyes;)

it would be nice if the LED only flashes _after_ the pwr up signal got accepted and the FR really starts up...

Change History

comment:1 Changed 10 years ago by john_lee

  • Owner changed from openmoko-devel to openmoko-kernel
  • HasPatchForReview unset
  • Component changed from unknown to System Software

comment:2 Changed 10 years ago by sushama

  • Cc testing@… added

verified the same. The AUX led flashes 2-3 seconds before the phone actually boots,I do feel a vibration as well at the same time the LED flashes. Can we have the LED light up at the same time the phone boots?

comment:3 Changed 10 years ago by Nytowl

  • Status changed from new to assigned
  • Owner changed from openmoko-kernel to andy

I think this is specific to u-boot. As we are moving forward with qi and don't remember seeing this with qi we should close this as won't fix or community. Andy ?

comment:4 Changed 10 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to wontfix

This whole bug is just a result of broken GTA02 (mainly A5, but to a lesser extent on A6 too) power circuit in hardware.

The only reason you get different behaviour depending on how long you hold the power button is because of insufficient VB_SYS capacitor to allow the device to start up properly.

While you hold the button, the failures to boot are hidden by "automatic retries" via the pcf50633 state machine. When you let go of the button "early", the miserable truth is revealed. But the pcf50633 button is in fact edge triggered action by design, with some debounce time.

To compound the perversity of this bug, on GTA02 A5 there is a problem with the amount of current the AUX LED driver draws, such that merely trying to light the AUX LED at all can itself directly cause the failure to boot and another hidden cycle of boot retry. So what you think of as a safety indicator is the smoking gun already.

So I doubt we really fix this as reported: closing as WONTFIX.

Note: See TracTickets for help on using tickets.