Ticket #1987 (closed defect: fixed)

Opened 10 years ago

Last modified 19 months ago

[Qt-Contact] contact name will have limit letters when export from phone to SIM

Reported by: wendy_hung Owned by: charlie
Priority: high Milestone: Om2008.10
Component: Qtopia Version: Om2008.8
Severity: critical Keywords: Om2008.11
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Summary:
conact name will have limit letters when export from phone to SIM

kernel:20080903-asu.stable-uImage.bin
root file system:20080910-asu.stable-rootfs.jffs2

Steps+current results:
1) create a contact name with more than 9 letters (with space is ok)(contact 1)
2) check contact detail and press option to Export contact to SIM
3) check contact list you'll see the contact name was cut only left 9 letters (contact 2)
4) import contact 2 to phone, you'll see it reduce letter again
5) if phone to SIM will have the limit, SIM to phone with out. The limit letter number is 9
6) please see attach photo (a bit ugly...sorry)

Expected:
no limit letters when export/import contacts

Attachments

limit letter.png (59.5 KB) - added by wendy_hung 10 years ago.

Change History

Changed 10 years ago by wendy_hung

comment:1 Changed 10 years ago by wendy_hung

  • Summary changed from [Qt-Contact] conact name will have limit letters when export from phone to SIM to [Qt-Contact] contact name will have limit letters when export from phone to SIM
  • Milestone changed from Om2008.9 to Om2008.10

comment:2 Changed 10 years ago by zecke

Charlie traced this down to the suffix Qtopia is using to declare SIM numbers as home, mobile, etc. numbers. A fix is pending.

comment:3 Changed 10 years ago by charlie

  • Status changed from new to in_testing

this patch :
http://git.openmoko.org/?p=qtopia.git;a=commit;h=50517a0d25ed72bff61ac3daf334c768c888b291

should at least fix the problem when importing into the sim.

For the other way around (going from the sim to the phone) it should be an other issue. Need to see with the testing guys what is going on exactly.

comment:4 Changed 10 years ago by wendy_hung

  • Owner changed from zecke to charlie
  • Status changed from in_testing to assigned
  • HasPatchForReview unset

[testing image]
test date:2008.11.05
update date:2008.11.05

This is not totally fixed yet...if over 12 letters still have limit.
I think we should define how many words that we can input?

comment:5 Changed 10 years ago by wendy_hung

  • Keywords Om2008.11 added

comment:6 Changed 10 years ago by charlie

  • Status changed from assigned to in_testing

The name is truncated when importing to SIM because there is a limitation of the contact name length in the SIM. This commit add a warning message when we modify the name :

http://git.openmoko.org/?p=qtopia.git;a=commit;h=7290a87162911f3ad57b4881919c53b89c662368


comment:7 Changed 10 years ago by sushama

  • Status changed from in_testing to closed
  • Resolution set to fixed

Testing image:28-nov-2008
Test date:28-nov-2008
When we export a contact from phone to SIM with more than 12 characters ,neo shows a warning message now. working as intended. Closed.

comment:8 Changed 19 months ago by JustDox

Propecia Libido Impotence <a href=http://cialis.ccrpdc.com/canadian-cheap-cialis.php>Canadian Cheap Cialis</a> Doxycycline Mexico Levitra Pareri <a href=http://viag1.xyz>Buy Viagra</a> Cheap Cheap Viagra Viagra A Casa <a href=http://kama1.xyz/order-cheap-kamagra.php>Order Cheap Kamagra</a> Kamagra To You Levitra Que Contiene <a href=http://priligy.ccrpdc.com/buy-priligy-cheap.php>Buy Priligy Cheap</a> The Blue Pill For Sale Cialis Sky Pharmacy <a href=http://cial1.xyz/brand-cialis-online.php>Brand Cialis Online</a> Zithromax Side Effects Rash Vente Du Cialis Sur Internet <a href=http://viagra.ccrpdc.com/cheap-viagra-pills.php>Cheap Viagra Pills</a> Viagra And On Line Prescription Vendo Viagra Malaga <a href=http://cial5mg.xyz/tadalafil-generic.php>Tadalafil Generic</a> Zithromax Uses Sildenafil 100mg Med <a href=http://cialis.ccrpdc.com/cheap-cialis-20mg.php>Cheap Cialis 20mg</a> Zithromax Dosage Pediatric Online Levaquin Internet <a href=http://cial1.xyz/cialis-prices.php>Cialis Prices</a> Cialis Generique Andorre Libera Vendita Cialis <a href=http://cial5mg.xyz/tadalafil-20mg.php>Tadalafil 20mg</a> Free Viagra Sample No Perscription Keflex Side Effects <a href=http://cial5mg.xyz/cialis-to-buy.php>Cialis To Buy</a> Cephalexin Through Iv Propecia Masa <a href=http://cial1.xyz/how-to-order-cialis.php>How To Order Cialis</a> Discount Super Viagra Baclofene Luxembourg <a href=http://cytotec.ccrpdc.com/order-generic-cytotec.php>Order Generic Cytotec</a> Le Cialis Generique Est Il Fiable Le Xenical Est Il En Vente Libre <a href=http://kama1.xyz/purchase-kamagra.php>Purchase Kamagra</a> order accutane online australia Amoxicillin Rash Pics <a href=http://viag1.xyz/cheap-viagra-usa.php>Cheap Viagra Usa</a> Cialis Nota 75 Levitra 12 Jours <a href=http://viagra.ccrpdc.com/cheap-viagra-samples.php>Cheap Viagra Samples</a> Prod 39 Priligy Ficha Tecnica <a href=http://cial1.xyz/brand-cialis-online.php>Brand Cialis Online</a> Viagra O Cialis Cual Es Mejor Buy Methotrexate 2 5 Mg No Rx Overnight <a href=http://zoloft.ccrpdc.com/prices-zoloft.php>Prices Zoloft</a> Keflex Infant Nursing Determining Correct Amoxicillin Dosage <a href=http://cial1.xyz/fast-delivery-cialis.php>Fast Delivery Cialis</a> Over The Counter Cephalexin Buy Vigora 100 <a href=http://zoloft.ccrpdc.com/zoloft-online-pharmacy.php>Zoloft Online Pharmacy</a> Come Comprare Cialis In Farmacia Buy Propecia Online Topix <a href=http://zol1.xyz/zoloft-generic-name.php>Zoloft Generic Name</a> Savella Dosage Of Amoxicillin Before Root Canal <a href=http://inderal.ccrpdc.com/propranolol-online-no.php>Propranolol Online No</a> Priligy Meinungen Euro Med Online <a href=http://cial1.xyz/cheap-cialis-tablets.php>Cheap Cialis Tablets</a> Buy Nitrofurantoin Mono Can Cephalexin Damage Liver <a href=http://kama1.xyz/kamagra-gel-online.php>Kamagra Gel Online</a> Naturliches Viagra How Last Longer <a href=http://lasix.ccrpdc.com/lasix-order.php>Lasix Order</a> Viagra Farmacia Italiana Rapid Tab <a href=http://cial5mg.xyz/online-cialis.php>Online Cialis</a> Viagra Achat Gratuit Flushed Face With Keflex Antibiotic <a href=http://cial1.xyz/tadalafil.php>?Tadalafil</a> Viagra And Cialis Sample Pack comnewsreleasesrenewfinancialraisesmingrowthcapital. APR Representative Foundation Card your home car or other assets. <a href=http://yourcashloan24.com>loans for people with bad credit</a> Read more Found a Loan Avoid these mistakes Even if you are not currently looking for a loan it is important to pay your financial obligations on time and ensure that you do not fall behind.Forum Cialis Soft Tabs <a href=http://zol1.xyz/buy-zoloft-on-line.php>Buy Zoloft On Line</a> Buy Viagra Uk Prednisone For Dogs Dosage Chart <a href=http://cial1.xyz/cheap-cialis-20mg.php>Cheap Cialis 20mg</a> Viagra Zutaten Does Amoxicillin Cure Chlamydia <a href=http://cial1.xyz/low-cost-cialis-online.php>Low Cost Cialis Online</a> Canadian Pharms Achat De Cialis En Ligne <a href=http://cial5mg.xyz/cialis-order.php>Cialis Order</a> Levitra Buy Us Pletal <a href=http://viag1.xyz/cheap-viagra.php>Cheap Viagra</a> Online Amoxicillin Order Metronidazole Or Tinidazole <a href=http://kama1.xyz/buy-cheap-generic-kamagra.php>Buy Cheap Generic Kamagra</a> Does Zithromax Treat Strep Mg Equivalent To Tsp Amoxicillin <a href=http://kama1.xyz/cheap-kamagra-uk.php>Cheap Kamagra Uk</a> Mail Order Medications From Canada Pharmacy Express Reviews <a href=http://cial5mg.xyz/cialis-tadalafil.php>Cialis Tadalafil</a> Cialis 20mg Lilly 12 Stuck Viagra 25mg Erfahrung <a href=http://zol1.xyz/zoloft-buy-online.php>Zoloft Buy Online</a> Propecia Nach 3 Monaten Buy Plavix 75 <a href=http://cial5mg.xyz/cialis-5mg.php>Cialis 5mg</a> Digoxin On Line Rx247 Viagra <a href=http://cial1.xyz/cialis-online.php>Cialis Online</a> Buy Xanical Online No Script Zithromax Rash Child <a href=http://viag1.xyz/purchase-viagra.php>Purchase Viagra</a> Viagra Tablette Teilen Buy Generic Cialis Online Canada <a href=http://kama1.xyz/generic-kamagra-buy.php>Generic Kamagra Buy</a> Fluticasone And Amoxicillin Purchase 5mg Cialis <a href=http://zol1.xyz/generic-zoloft.php>Generic Zoloft</a> Cialis 20 Mg Foglio Illustrativo Order Macrobid 100mg Windsor <a href=http://kama1.xyz/buy-kamagra-usa.php>Buy Kamagra Usa</a> Strep Throat Dosage Amoxicillin Dog Pyometra Cephalexin <a href=http://antabuse.ccrpdc.com/antabuse-price.php>Antabuse Price</a> Clomid Culturiste Viagra Professional Canadian <a href=http://kama1.xyz/buy-kamagra-gel.php>Buy Kamagra Gel</a> Vendita Viagra Prezzi Rogaine Y Propecia <a href=http://viag1.xyz/buy-viagra-online.php>Buy Viagra Online</a> Acquistare Il Cialis Frontal Baldness Propecia Approved <a href=http://zol1.xyz/purchase-zoloft.php>Purchase Zoloft</a> Vademecum O Propecia Amoxicillin Online Without <a href=http://prozac.ccrpdc.com/prozac-generic.php>Prozac Generic</a> Cytotec Et Pose De Mirena CytotecР’В® Prix Pharmacie <a href=http://kama1.xyz>Buy Kamagra</a> Order Viagra Online

Note: See TracTickets for help on using tickets.