Ticket #1991 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

[Suspend] unable to suspend, just stay black screen after wake up by power button from suspend

Reported by: regina_kim Owned by: matt_hsu
Priority: high Milestone: Om2008.10
Component: kernel Version:
Severity: critical Keywords:
Cc: testing@… Blocked By: #1789, #1985, #1996, #2020
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: sometimes

Description

kernel : 20080903
rootfs : 20080911

Description : unable to suspend, just stay black screen after wake up by power button from suspend

step+current result :

1.set suspend time (10, 30, 60 sec)
2.press power button to wakes it up when it goes into suspend
3.wait until goes to suspend

----> but it just goes black screen

expected result : it should go to suspend.

Attachments

Wed Oct 29 15-13-15 CST 2008.log (41.6 KB) - added by wendy_hung 6 years ago.

Change History

comment:1 Changed 6 years ago by wendy_hung

relate bug #1992, thanks for thepizzaking help us to get the log.

Let me discrib this bug more...
this bug means first time you set suspend time you'll have suspend time, but once you wake it up by power button, the second suspend time will fail (become blank time) you can click the screen to wake it up. So if this time you press the power button try to wake it up, actually is bring it to suspend time(use power button to suspend).
After second suspend (blank time) it still will go into suspend (third suspend) than this time you'll have really suspend time....

Hope this is clear enough. :)

comment:2 follow-up: ↓ 3 Changed 6 years ago by andy

There's one thing extra about description that would help a lot, "black screen" or "blank screen" is very hard to know exactly what it means.

What we need to know is if the backlight is on or not. If the screen shows all black pixels with the backlight on, you can still see some light coming through if you take the device to a dark place. If the backlight is off though, it will be completely black all the time. Those two kinds of "black screen" are very different for us.

comment:3 in reply to: ↑ 2 Changed 6 years ago by h.koenig

this sounds very familar to me -- see bug #1985.

at least in my case it looks like the backlit is off:

root@om-gta02:~# head /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/backlight/pcf50633-bl/*bright*
==> /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/backlight/pcf50633-bl/actual_brightness <==
0

==> /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/backlight/pcf50633-bl/brightness <==
63

==> /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/backlight/pcf50633-bl/max_brightness <==
63

comment:4 follow-up: ↓ 5 Changed 6 years ago by wendy_hung

Hey Andy :)
thanks for your notice, I checked with commend line and it show up this:
root@om-gta02:~# cat /sys/class/backlight/pcf50633-bl/brightness
63

So I think the backlight is on...

comment:5 in reply to: ↑ 4 Changed 6 years ago by h.koenig

Replying to wendy_hung:

Hey Andy :)
thanks for your notice, I checked with commend line and it show up this:
root@om-gta02:~# cat /sys/class/backlight/pcf50633-bl/brightness
63

So I think the backlight is on...

you have to check actual_brightness (see my last comment)...

comment:6 Changed 6 years ago by will

  • Milestone changed from Om2008.9 to Om2008.10

comment:7 Changed 6 years ago by will

  • Owner changed from openmoko-devel to openmoko-kernel
  • Component changed from unknown to System Software

comment:8 Changed 6 years ago by wendy_hung

  • Status changed from new to assigned
  • Owner changed from openmoko-kernel to matt_hsu

Tested with the base image, still sometimes happen like that.
Had shown this to Matt.

Tested day:2008.10.07
sorry already updated so can't attach a opkg list_installed...

Will keep track on this bug. :)

comment:9 Changed 6 years ago by wendy_hung

  • HasPatchForReview unset
  • Milestone Om2008.10 deleted

test date:2008.10.31
update date:2008.10.29
Installed_list:as attach

Test with this testing image, it doesn't happen with this problem, but i would like to double check that. Close this one later.

Changed 6 years ago by wendy_hung

comment:10 Changed 6 years ago by wendy_hung

  • Milestone set to Om2008.10

sorry, don't know why milestone will be delete....

comment:11 Changed 6 years ago by john_lee

  • Blocked By 1789, 1985, 1996, 2020 added

I will add similiar bugs here so it's easier to track.

comment:12 Changed 6 years ago by jeremy

Thanks Wendy's test and explanation, it sounds it's goes to Blank, but not going to Suspend. And the user will misunderstand it should have already suspended cause the screen is black. Hopefully there will be a logread log for this issue cause #1992 I think is for another issue that is suspending happens right after the resume manually by pressing the power button.

comment:13 Changed 6 years ago by andy

Is this problem still seen with recent 2.6.29 kernels?

comment:14 Changed 6 years ago by wendy_hung

Tested with Paroli image doesn't have the Auto suspend function, but use the Power button to suspend/resume won't have this problem so far.

comment:15 Changed 5 years ago by PaulFertser

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.