Ticket #1992 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

Suspend/Resume plays up when initiated manually

Reported by: thepizzaking Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: thepizzaking@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

When I set my phone to suspend automatically after 30 seconds and then initiate suspend manually (by pressing the power button). I then wait more than 30 seconds and press the power button again to resume, it wakes up and then goes straight back to sleep, probably thinking that nothing's happened for 30 seconds so it should sleep. Pressing the power button again makes it wake up and stay on, even if you don't press it within another 30 seconds. Also, letting it automatically suspend after 30 seconds doesn't cause this issue on resume.

A logread after resuming is attached. Along with opkg list_installed.
This is from a rootfs from 29th August 2008 and updated until today (11th September) on stable.

Attachments

logread (63.3 KB) - added by thepizzaking 11 years ago.
logread after resume
list_installed (41.7 KB) - added by thepizzaking 11 years ago.
list of installed files

Change History

Changed 11 years ago by thepizzaking

logread after resume

Changed 11 years ago by thepizzaking

list of installed files

comment:1 Changed 11 years ago by wendy_hung

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate bug than #1991, thanks for your logread, lets comment more in #1991. :)

comment:2 Changed 11 years ago by jeremy

  • HasPatchForReview unset

I think this issue will be solved, if #2113 solved.

Note: See TracTickets for help on using tickets.