Ticket #2020 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

USB connection messes with suspend/resume state machine

Reported by: vnevoa Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version: Om2008.8
Severity: normal Keywords:
Cc: testing@… Blocked By:
Blocking: #1991 Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Software: up-to-date "OM2008.8-update" with original feeds (Timestamp = Mon 15 Sep 2008 09:58:59 +0800)

Blank time = 15 seconds.
Suspend aftr blank time = 1 second.

Steps to reproduce:

1 - with FR suspended, connect USB cable -> FR resumes;
2 - wait for suspend timeouts -> FR dimms the screen but does not suspend (charging LED stays on, illume icons are visible if an external light source is used) and will not suspend while USB is connected;

This seems ok to me. Continuing...

3 - disconnect USB cable -> charging LED turns off but:

-> screen does not glow back up;
-> FR will not suspend after any timeouts, stays always on;
Both of these things seem wrong to me!

4 - touch the screen -> FR glows up the screen;
5 - wait for suspend timeouts -> FR dimms but does not suspend;

6 - touch the screen -> FR glows up the screen;
7 - wait for suspend timeouts -> FR does dimm and suspend;

Now I know how my FR sometimes exausts the battery at night!! It is still turned on, but the screen is dimmed.

The same can happen if the USB is connected. Reproduce steps 1 and 2, then don't disconnect USB, and steps 4 to 7 still happen.

Attachments

logread.txt (63.9 KB) - added by vnevoa 11 years ago.
dmesg.txt (15.5 KB) - added by vnevoa 11 years ago.

Change History

Changed 11 years ago by vnevoa

Changed 11 years ago by vnevoa

comment:1 Changed 11 years ago by marek

That sounds a bit similar to #1991 ?! What do you think ?

comment:2 Changed 11 years ago by vnevoa

Yes, it does look like a duplicate.
However, I thought my case was different because it seems linked to USB connection, which I think was deliberately taken into consideration by the developers in the suspend/resume system?...
If what I say does not make sense, then go ahead and mark it as duplicate.

comment:3 Changed 11 years ago by wendy_hung

I think it's partally duplicate, #1991 when we use the USB cable it does not happen with this problem, at least, it will wake up when we plug out the USB cable.

Today i tested with today's image (Timestamp = Mon 22 Sep 2008 08:22:15 +0800)
It have the same problem, the only different is it will glow back up-wake up from suspend.
We will continue track this problem.
Thanks for notice us. :)

comment:4 Changed 11 years ago by wendy_hung

  • Cc testing@… added

comment:5 Changed 11 years ago by vnevoa

I'm thinking this has little or nothing to do with USB.
From the point of view of usage, USB plug-in and plug-out looks like just another APM event, like for example clicking the power button.

New use-case info: (after opkg update + upgrade today = no pkg changes)
1 - let FR go to sleep (without USB cable);
2 - click power button -> FR wakes up, glows screen;
3 - wait for timeout -> FR dims screen but does not go to sleep (icons still showing if strong light used);
4 - touch screen -> FR glows screen;
5 - wait for timeout -> FR dims screen and goes to sleep.

This is consistent with the first description, but without the USB thing.

Another interesting fact:
1 - let FR go to sleep (without USB cable);
2 - click power button -> FR wakes up, glows screen;
3 - touch screen once -> nothing happens! (illume does not receive the click);
4 - touch the screen again -> illume receives the click and acts normally (launch app, slide icons, etc.);
However, after step 3 (touching the screen and nothing seems to happen) the timeout starts to count down, because if we don't do anything after that it effectively goes to sleep.

My conclusion: when FR wakes up, there is "something X11" waiting for a click to initiate the power management countdown. If there is no screen tapping, there is no countdown to sleep (although there is countdown to screen dimming).

comment:6 Changed 11 years ago by vnevoa

NOTE: whenever I say "let FR go to sleep", please make sure it is really sleeping!! (touch screen - if it glows, it wasn't really sleeping) :)
Otherwise, the test isn't valid.

comment:7 Changed 11 years ago by john_lee

  • Blocking 1991 added

(In #1991) I will add similiar bugs here so it's easier to track.

comment:8 Changed 10 years ago by PaulFertser

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed

Not kernel/bootloader issue. Not reproducible with the latest SHR.

Note: See TracTickets for help on using tickets.