Ticket #2025 (closed defect: fixed)

Opened 9 years ago

Last modified 3 months ago

Glamo problem: 4GB SD I/O errors with glamo_mci.sd_max_clk=10000000 and no suspend

Reported by: GNUtoo Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version:
Severity: blocker Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Hello,
i've tried to install debian 2008.8 and 2008.9 on a 4GB micro-sd card(MMBGR04GUACY-NA) and it always exits from the install sooner or later because of I/O errors...
Once i've even successfully done the following without I/O errors:
dd if=/dev/urandom of=./random
but when i deleted random i did get I/O errors.
I'll attach a full dmesg log

Attachments

dmesg (15.3 KB) - added by GNUtoo 9 years ago.
dmesg before the debian install
logread.txt (93.7 KB) - added by GNUtoo 9 years ago.
logread > logread.txt && logread -f>>logread.txt then head -n 1000 logread.txt

Change History

comment:1 Changed 9 years ago by GNUtoo

I've also had 2 screen corruption:
*the first time that i've got a tv-like corruption
*the second time it was like when a CRT monitor had the wrong frequency: one night i kept it on and connected to the power trough the power and it gave me that corruption.

here's my setup:
# cat /proc/cmdline
glamo_mci.sd_max_clk=10000000 rootfstype=jffs2 root=/dev/mtdblock6 console=ttySAC2,115200 console=tty0 loglevel=8 regular_boot mtdparts=physmap-flash:-(nor);neo1973-nand:0x00040000(u-boot),0x00040000(u-boot_env),0x00800000(kernel),0x000a0000(splash),0x00040000(factory),0x0f6a0000(rootfs)
2008.9 distribution

Changed 9 years ago by GNUtoo

dmesg before the debian install

Changed 9 years ago by GNUtoo

logread > logread.txt && logread -f>>logread.txt then head -n 1000 logread.txt

comment:2 Changed 9 years ago by GNUtoo

the debian install exited at this point:
P: Configuring helper cdebootstrap-helper-rc.d
E: Internal error: install

comment:3 Changed 9 years ago by andy

I think we will find everything about this that is to do with SD Card is downstream of the real problem, which seems to be Glamo communication generally.

Unfortunately the kernel you're running is before the change to Memory clock PLL on Glamo from 81 -> 89MHz, that would have been a nice explanation that some Glamo devices can't handle it. But you are already at 81MHz.

Where did this kernel come from, is it a normal packaged kernel?

comment:4 Changed 9 years ago by GNUtoo

this time the kenrel comes from 2008.9...stock kernel...

comment:5 Changed 9 years ago by john_lee

  • Owner changed from openmoko-devel to openmoko-kernel
  • HasPatchForReview unset
  • Component changed from unknown to System Software

comment:6 Changed 9 years ago by kd8ikt

i get this with a 4gb class 6 sdhc when trying to mkfs to anypartition wich seems to be past the 1GB marker,fdisk says the drive is a little over 4gb that cant be right normally its the other way around

comment:7 Changed 8 years ago by PaulFertser

  • Status changed from new to closed
  • Resolution set to fixed

Please try with the maximum sd_drive (sd lines drive strength) setting.

There're known issues with some cards that pick GSM interference and refuse to work while others in the same device and network conditions work ok. I'm not sure anything can be done with this, just try to get a card that works good.

Fixing as "all the relevant glamo sdi tweaks are exposed to user, we can't do any better".

comment:8 Changed 3 months ago by JustDox

Quand Prendre Le Cialis <a href=http://zol1.xyz/zoloft-cheap.php>Zoloft Cheap</a> Buy T4 Online Vmax Viagra <a href=http://zol1.xyz/purchase-cheap-zoloft.php>Purchase Cheap Zoloft</a> Kamagra Oral Jelly Ajanta Can Amoxicillin Cause False Positives <a href=http://cial1.xyz/buy-cialis-online-cheap.php>Buy Cialis Online Cheap</a> Sildenafil Generic Cheapeast Secure Macrobid Medication Ups Express Delivery Visa Accepted <a href=http://zol1.xyz/cost-of-zoloft.php>Cost Of Zoloft</a> Diflucan For Sale Acquistare Kamagra Online Di Quebec <a href=http://cial1.xyz/cialis-5mg.php>Cialis 5mg</a> Propecia Knoll Amoxicillin Coumidan <a href=http://cial1.xyz/generic-cialis-online.php>Generic Cialis Online</a> Buy Finasteride In Singapore Propecia Dopaje <a href=http://viag1.xyz/sildenafil-citrate.php>Sildenafil Citrate</a> isotretinoin direct Hydrochlorothiazide Hypertension Renfrewshire <a href=http://zol1.xyz/zoloft-online-prices.php>Zoloft Online Prices</a> Cialis Lilly Precio Renovables A Propecia <a href=http://viag1.xyz/viagra-samples.php>Viagra Samples</a> Keflex Anitbiotic For Abscess Tooth Keflex Used For Tonsilitis <a href=http://cial1.xyz/cialis-20mg-price.php>Cialis 20mg Price</a> Buy Strattera Atomoxetine Usa Online Cephalexin Kidney Infection <a href=http://cial5mg.xyz/cheap-cialis-tablets.php>Cheap Cialis Tablets</a> Viagra Cialis Online Pharmacy Cialis Donde Comprar Espana <a href=http://cial5mg.xyz/order-generic-cialis.php>Order Generic Cialis</a> Prix Du Viagra En Algerie Swww Healthy Man Viagra <a href=http://kama1.xyz/kamagra-en-ligne.php>Kamagra En Ligne</a> Generique Amoxicillin Sans Ordonnance En Ligne Erexin V <a href=http://cial5mg.xyz/need-to-order-cialis.php>Need To Order Cialis</a> Online Amoxil Without Prescription Clomid Date Regles <a href=http://viag1.xyz/map.php>Sildenafil</a> Online Pharmacy Malegra Fast Delivery Viagrabest Online Price <a href=http://cial1.xyz/cheapest-cialis.php>Cheapest Cialis</a> Kamagra Uk Fast Cephalexin Dose For Dog <a href=http://kama1.xyz/online-generic-kamagra.php>Online Generic Kamagra</a> Does Generic Viagra Really Work Viagra Et Hypertension Arterielle <a href=http://kama1.xyz/kamagra-online-buy.php>Kamagra Online Buy</a> Caniadan Online Pharmacy Meglio Viagra O Levitra <a href=http://viag1.xyz/viagra-online-online.php>Viagra Online Online</a> Is Cephalexin A Quinolone Antibiotic Il Sр“в»r D'Acheter En Ligne Priligy <a href=http://inderal.ccrpdc.com/buy-propranolol-online-usa.php>Buy Propranolol Online USA</a> Valtrex Discount Program Canadian Pharmacy Meds Online <a href=http://cial5mg.xyz/order-cialis-tablets.php>Order Cialis Tablets</a> Alfusin

Note: See TracTickets for help on using tickets.