Ticket #2030 (closed defect: wontfix)

Opened 9 years ago

Last modified 8 years ago

Cannot connect to WEP network

Reported by: tkep Owned by: marek
Priority: high Milestone:
Component: Network Manager Version:
Severity: normal Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Using FDOM, ASU 2008.8 and ASU 2008.9, it is impossible to join my home and work WEP enabled network using the "Settings" application.

It could have something to do with the fact that when typing the key in using the QWERTY keyboard, it appears that more characters are being echoed than are actually being typed. The first character of each string seems to echo an extra time (once for when it is pressed, then once when it is accepted as it were). So if the key is 1234, I would see *. That is one too many characters. However this could be completely unrelated.

I can connect to the same network when I turn WEP off. But at work, there is no possibility. It'd be nice to be untethered and have fast internet. :)

If you need anything more from me on this, let me know.

Change History

comment:1 Changed 9 years ago by marek

  • Priority changed from normal to high
  • Cc testing@… added
  • Reproducible set to always
  • Component changed from unknown to Network Manager
  • Owner changed from openmoko-devel to raster

Recently we investigated the WiFi? connection issues. During that process I had a deeper look at the network manager (connman) sources which are used by the stettings UI. It turns out that it does not support any encryption method other than WPA-PSK.
We put the network manager on the table again and are looking at other options.

comment:2 Changed 9 years ago by marek

  • Owner changed from raster to marek
  • Status changed from new to accepted

comment:3 Changed 8 years ago by marek

  • Status changed from accepted to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

The WiFi UI can't be fixed that soon. The support has been removed. See bug #1734 for details.

Note: See TracTickets for help on using tickets.