Ticket #2036 (closed defect: duplicate)

Opened 9 years ago

Last modified 8 years ago

resize2fs /dev/mmcblk02p2 128m seg faults

Reported by: Niko! Owned by: openmoko-devel
Priority: highest Milestone:
Component: unknown Version:
Severity: blocker Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

root@om-gta02:~# cat /proc/partitions
major minor #blocks name

31 0 2048 mtdblock0
31 1 256 mtdblock1
31 2 256 mtdblock2
31 3 8192 mtdblock3
31 4 640 mtdblock4
31 5 256 mtdblock5
31 6 252544 mtdblock6

179 0 498176 mmcblk0
179 1 7836 mmcblk0p1
179 2 490336 mmcblk0p2

root@om-gta02:~# e2fsck -f /dev/mmcblk0p2
e2fsck 1.38 (30-Jun-2005)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/mmcblk0p2: 7705/122880 files (0.9% non-contiguous), 119562/490336 blocks

resize2fs 1.38 (30-Jun-2005)
Resizing the filesystem on /dev/mmcblk0p2 to 131072 (1k) blocks.
Segmentation fault

Attachments

opkg_list (45.5 KB) - added by Niko! 8 years ago.
Output of opkg list_installed

Change History

comment:1 Changed 9 years ago by Niko!

Please correct severity and priority! it was a mistake.

comment:2 Changed 8 years ago by zecke

  • Owner changed from julian_chu to openmoko-devel
  • Component changed from Distro to unknown

Okay. I think I already pointed you to http://wiki.openmoko.org/wiki/Bug_Filing_Policy this means the next bug will be just closed as "Invalid" according to the policy. This is not bad will but writing this consumes engineering time that could be better spend on reviewing patches or fixing actual bugs.

You set a component and shouldn't have set one, you are supposed to append the output of opkg list_installed and you didn't. Specially the last part is something that is really missing in this case.

Please append the required files.

Changed 8 years ago by Niko!

Output of opkg list_installed

comment:3 follow-ups: ↓ 4 ↓ 5 Changed 8 years ago by Niko!

Hi zeche, i was stucked when i read i set the component again! but now i'm happier becouse i know that the problem is a bug in my mind: I tipically tend to reset a combobox selecting the first item (usually it's blank or "--" or similiar) that there was "Distro".
I'll be more carefull the next time, because i'm an engineer too and already know
how much important is time for all, openmoko employees, volunteers and why not bug reporters :)
Howewer may you consider to remove from the new ticket form the unnecessary combobox?
it would solve the problem definitively.

Now let's return to the problem.
I attached the installed list of packages.

it would be interesting that resizefs works fine on the last FSO unstable image.

comment:4 in reply to: ↑ 3 Changed 8 years ago by zecke

Replying to Niko!:

Howewer may you consider to remove from the new ticket form the unnecessary combobox?
it would solve the problem definitively.

Yes, it is a matter of time. Our admins have a pile of things to do as well.

comment:5 in reply to: ↑ 3 Changed 8 years ago by zecke

Replying to Niko!:

it would be interesting that resizefs works fine on the last FSO unstable image.

was this a question or already an statement?

comment:6 Changed 8 years ago by Niko!

Sorry, I tested it and it worked fine.

comment:7 Changed 8 years ago by Niko!

Hi zeche,
Finally i got the time to backup my phone and redo the test in a sistematic way, to give you a method to reproduce it.
I flashed and reflashed my device different times with 2008.9, fso-milestone-3 and fso-unstable, and i got always the seg fault.
This was a surprise for me, as i'm sure i resized the card partition successfull with fso.
Just now i decided to delete partition and to recreate and format it, and resize2fs worked well with all the distro!

So i really suppose that sometingh similiar to bug #1802 occourred, but apparently the partition table was good.

You may close this issue, and if i'll be able to reproduce it i'll report a comment on #1802 or where it fits better.

Regards

Nicola

comment:8 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to duplicate

ok, closed as duplicate.

Note: See TracTickets for help on using tickets.