Ticket #2039 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

dfu-util recognize 044e:300c Alps Electric Co., Ltd as an openmoko phone

Reported by: GNUtoo Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

$ ./dfu-util -l
dfu-util - (C) 2007 by OpenMoko? Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

Found Runtime: [0x044e:0x300c] devnum=0, cfg=0, intf=2, alt=0, name="UNDEFINED"
Found Runtime: [0x1d50:0x5119] devnum=0, cfg=0, intf=2, alt=0, name="UNDEFINED"
# lsusb
Bus 009 Device 001: ID 1d6b:0002
Bus 002 Device 003: ID 0ac8:c001 Z-Star Microelectronics Corp.
Bus 002 Device 001: ID 1d6b:0002
Bus 008 Device 001: ID 1d6b:0001
Bus 007 Device 002: ID 044e:300c Alps Electric Co., Ltd
Bus 007 Device 001: ID 1d6b:0001
Bus 001 Device 003: ID 04b4:6830 Cypress Semiconductor Corp. USB-2.0 IDE Adapter
Bus 001 Device 001: ID 1d6b:0002
Bus 006 Device 001: ID 1d6b:0001
Bus 005 Device 002: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 005 Device 001: ID 1d6b:0001
Bus 004 Device 004: ID 1d50:5119
Bus 004 Device 001: ID 1d6b:0001
Bus 003 Device 002: ID 04fc:0003 Sunplus Technology Co., Ltd CM1092 Optical Scroller Mouse
Bus 003 Device 001: ID 1d6b:0001

Change History

comment:1 Changed 6 years ago by zecke

  • Status changed from new to closed
  • Resolution set to invalid

Sorry, this is not a bug. dfu-util is implementing the DeviceFirmwareUpgrade? (DFU) Protocol. The freerunner is not the only device implementing this protocol. Many bluetooth devices implement it as well. dfu-util -l is listing all devices that can be upgraded with dfu-util.

http://wiki.openmoko.org/wiki/USB_DFU should have more information on the protocol.

comment:2 Changed 6 years ago by andy

FWIW, I use the following script to update kernel, which includes a switch for intentify the two aspects of GTA02 U-Boot identity:

#!/bin/bash
../../dfu-util/src/dfu-util -a 3 -d 0x1d50:0x5119 -D uImage.bin
if [ $? -eq 1 ] ; then
../../dfu-util/src/dfu-util -a 3 -d 0x1d50:0x5120 -D uImage.bin
../../dfu-util/src/dfu-util -a 3 -d 0x1d50:0x5119 -D uImage.bin

fi

Note: See TracTickets for help on using tickets.