Ticket #2044 (closed task: fixed)

Opened 11 years ago

Last modified 10 years ago

om-locations - map licensing

Reported by: drlizau Owned by: Nytowl
Priority: highest Milestone:
Component: Distro Version:
Severity: normal Keywords:
Cc: olv, tick Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The maps from OpenStreetMap? used in om-locations require attribution according to the CC-by-SA licence.
The wiki page indicates that the maps come from OSM. There does need to be indication with the downloaded maps that they are from OSM.
May I suggest that in the package information which is read prior to download through assassin this information is included
for example

om-maps-london
Openmoko Software 20080430-r0
Download size 17156KB

Map of London, for use with Locations application.
Data from OpenStreetMap?.org, licenced CC-by-SA.

reference: http://wiki.openstreetmap.org/index.php/Common_licence_interpretations#I_want_to_use_OSM_data_with_my_GPS_routing.2Fmapping.2Fother_application.__Do_I_have_licence_the_application_under_the_OSM_licence.3F

Attachments

0001--maps-Attribute-to-OpenStreetMap.patch (4.9 KB) - added by olv 11 years ago.
0002--maps-Add-map-of-low-levels.patch (1.7 KB) - added by olv 11 years ago.
0003--om-locations-Bump-up-the-revision.patch (939 bytes) - added by olv 11 years ago.

Change History

comment:1 Changed 11 years ago by zecke

  • Cc olv, tick added
  • Priority changed from normal to highest
  • Component changed from unknown to Distro
  • Owner changed from openmoko-devel to julian_chu
  • Milestone Om2008.9 deleted

I will move this to "Distro" as this is where the package comes from. We should have CC-by-SA in the LICENSE field. The question is where the attribution needs to happen? Is it good enough to put attribution into the package description or should the application using the data attribute openstreetmap?

I will try to discuss with the engineers involved. Sorry about not honoring the license, we should do better.

comment:2 Changed 11 years ago by drlizau

The application does not have to attribute OSM, but I am waiting on further advice from OSM-legal-talk mailing list. Then I can make a few broader notes on the wiki to explain the licensing of the data.

comment:3 Changed 11 years ago by olv

All map packages have

LICENSE = "Creative Commons Attribution-ShareAlike? 2.0"

in the .bb. But there is no(?) indication in the installer. Nor attribution to OpenStreetMap?.

I am really sorry about my oversight, and I would love to do whatever needed to make it clear the map data are from OSM and honor the license and hard works of the OSM folks.

Changed 11 years ago by olv

Changed 11 years ago by olv

Changed 11 years ago by olv

comment:4 follow-up: ↓ 5 Changed 11 years ago by olv

The above patches to OE

  1. mention the licence of the map packages and attribute the work to OpenStreetMap? in the package description,
  2. add a map package for low level tiles,
  3. bump up the revision of om-locations so that the low level tiles do not distribute with it.

I am not sure whether patch 2 & 3 are necessary, and I am not sure whether patch 1 is enough. But I hope this is a start point for discussion.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 11 years ago by drlizau

Replying to olv:

The above patches to OE

  1. mention the licence of the map packages and attribute the work to OpenStreetMap? in the package description,
  2. add a map package for low level tiles,
  3. bump up the revision of om-locations so that the low level tiles do not distribute with it.

I am not sure whether patch 2 & 3 are necessary, and I am not sure whether patch 1 is enough. But I hope this is a start point for discussion.

OSM-legal-talk advice (which isn't advice from legal practitioners, but from those interested) is

In the mean time, the advice to credit maps and distributed data with the
phrase 'map data CCbySA www.openstreetmap.org' seems sensible advice!

thankyou very much for looking at this for us.
Your apologies have been sent to the same mailing list.

comment:6 in reply to: ↑ 5 Changed 11 years ago by olv

Replying to drlizau:

thankyou very much for looking at this for us.
Your apologies have been sent to the same mailing list.

Thanks for the help. I am sincerely sorry not doing it right in the first place.

zecke has helped apply the patches to our repo (http://git.openmoko.org/?p=openmoko.git;a=commit;h=a8e3e8c9628479ba0d53057e34a8fa104d52fb35). Our daily build will start rebuilding the packages since tomorrow.

@zecke:

Could you help cherry-pick them back into asu.stable branch? It should be trivial, except that om-locations is built from 0.2 branch and has a different revision:

http://git.openmoko.org/?p=om-locations.git;a=commit;h=7ed670a83c945fb3a740f7ebbcb14836b71b7e7f

comment:7 Changed 11 years ago by olv

@zecke:

Off topic issue.

Is it possible to have om-locations RECOMMEND om-maps-low-levels? So that users do not get confused after they upgrade.

comment:8 Changed 10 years ago by john_lee

  • Status changed from new to in_testing
  • HasPatchForReview unset

if it's in testing repo now then we should change status to in testing.

comment:9 Changed 10 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:10 Changed 10 years ago by Nytowl

  • Status changed from in_testing to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.