Ticket #205 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

add code to u-boot to query hardware revision and serial number from GSM Modem

Reported by: laforge@… Owned by: jserv@…
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: minor Keywords:
Cc: buglog@…, jserv@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Once we have the new GSM firmware, we should add code to query the GSM Modem for
hardware revision and serial number information and use this as basis for
ATAG_REVISION and ATAG_SERIAL as well as the 'iSerial' string of the USB device
code.

Change History

comment:1 Changed 12 years ago by laforge@…

this should now be quite easy since we already have all the pieces in place to
talk with the GSM modem (terminal mode, passthrough, power up/down).

comment:2 Changed 12 years ago by sean_chiang@…

Using AT+CGMR can get the info, so try to send this command at u-boot
AT+CGMR
+CGMR: "HW: GTA01Bv4, GSM: gsm_ac_gp_fd_pu_em_cph_ds_vc_cal35_ri_36_amd8_ts0-Moko1"

comment:3 Changed 12 years ago by jserv@…

  • Cc jserv@… added
  • Owner changed from laforge@… to jserv@…

comment:4 Changed 12 years ago by jserv@…

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in revision 2929

Note: See TracTickets for help on using tickets.