Ticket #2082 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

No icons in illume

Reported by: john_lee Owned by: raster
Priority: highest Milestone:
Component: E - Illume Version:
Severity: blocker Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Since EFL_SRCREV 36520, there's no icons in illume, so the user cannot launch anything. My current EFL is 36882 and the problem is still there.

Attachments

x.log (6.0 KB) - added by john_lee 5 years ago.

Change History

Changed 5 years ago by john_lee

comment:1 Changed 5 years ago by gromgull

(me too - no input - I'd just like to be CC'd)

comment:2 Changed 5 years ago by john_lee

after upgrade om.dev to match with upstream and test with the illume default config and theme, the icons appeared again, but Enlightenment SIGABRT'd with the following message in x.log:

* ECORE ERROR: Ecore Magic Check Failed!!!
* IN FUNCTION: ecore_evas_move()

Input handle is wrong type

Expected: 76543211 - <UNKNOWN>
Supplied: 00000000 - <UNKNOWN>

* NAUGHTY PROGRAMMER!!!
* SPANK SPANK SPANK!!!
* Now go fix your code. Tut tut tut!


process 2249: type invalid 0 not a basic type

D-Bus not built with -rdynamic so unable to print a backtrace

ABORT

comment:3 Changed 5 years ago by john_lee

  • Status changed from new to in_testing

Fixed. Thanks for raster's help.

comment:4 Changed 5 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

it had fixed.

comment:5 Changed 5 years ago by pooze

How does one apply this fix? I don't see any patches or intructions in any way. I updated with the testing repos today and the issue was still there.

comment:6 Changed 5 years ago by regina_kim

i have tested below image
flash image :2008.10.28
update : 2008.10.29

comment:7 Changed 5 years ago by wendy_hung

sorry, i did opkg update and upgrade today. Can't get this problem the same as before. Could you tell us more detail about how you did your update? Help us to reproduce that.

comment:8 Changed 5 years ago by gromgull

The fix only works with certain themes or combinations there-of, see:

http://lists.openmoko.org/pipermail/community/2008-October/034881.html

comment:9 Changed 5 years ago by pooze

I followed the link to the mailinglist above, and now the icons are back. Thanks.

What I did, however, was to flash http://downloads.openmoko.org/releases/Om2008.9/Om2008.9.rootfs.jffs2 and its kernel to the phone. Then I did an opkg update && opkg upgrade, which didn't give me as many updates as I was hoping for, so I edited the opkg files to point to the testing repositories. Then another opkg update && opkg upgrade which took a while. Then my icons were gone. Apparently because I'd gotten a combination of illume-themes and illume-configs that wasn't compatible or something. But force-removing these packages and installing the ones suggested by the mail seemed to work for me.

But I was surprised to see the bug fixed in the tracker before I got the error myself only by using opkg updates in the testing repo. Can any of you reproduce it using the file I pointed to? Or should I try to reproduce it here once more to see if it's still an issue?

Note: See TracTickets for help on using tickets.