Ticket #2084 (closed defect: wontfix)

Opened 5 years ago

Last modified 5 years ago

CRC Fail on boot , long boot time before init , wireless isnt detected

Reported by: Zoup Owned by: julian_chu
Priority: highest Milestone:
Component: Distro Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Well , its all in summary , i have to add that its tested with latest daily kernel and om2008.9 , dmesg is attached , let me know if you need more detail .

Attachments

dmesg (15.3 KB) - added by Zoup 5 years ago.
lshal (54.1 KB) - added by Zoup 5 years ago.
Lshal
full-dmesg (21.9 KB) - added by Zoup 5 years ago.

Change History

Changed 5 years ago by Zoup

Changed 5 years ago by Zoup

Lshal

comment:1 Changed 5 years ago by Zoup

i had
GTA02v6 # setenv bootcmd setenv bootargs \${bootargs_base} \${mtdparts} \${extra}\; nand read.e 0x32000000 kernel 0x200000\; bootm 0x32000000
GTA02v6 # setenv extra log_buf_len=2M
GTA02v6 # saveenv

and

dmesg -s 2000000 >full-dmesg

which i attached

Changed 5 years ago by Zoup

comment:2 Changed 5 years ago by Zoup

i have to add that the eth0 was detected ( i have not tried connecting to AP's ) before some Uboot upgrade , but same result when i try to boot from NOR .

comment:3 Changed 5 years ago by Zoup

well , ill simply die if it is hardware problem , after my headphone jack issue i bought new device and to use old one for Experiments , well ...

this is /proc/interrupts

CPU0

16: 12598 s3c-ext0 lis302dl
17: 1 s3c-ext0 modem
30: 63962 s3c S3C2410 Timer Tick
33: 0 s3c s3c24xx_hcd
35: 6626 s3c I2S PCM Stereo out
37: 100149 s3c S3c24xx SDIO host controller
41: 2691 s3c s3c2410_udc
42: 0 s3c ohci_hcd:usb1
43: 516 s3c s3c2440-i2c
48: 1 s3c-ext Neo1973 Headphone Jack
49: 0 s3c-ext ar6000
50: 1 s3c-ext Neo1973 AUX button
51: 1 s3c-ext Neo1973 HOLD button
53: 2 s3c-ext pcf50633
60: 13457 s3c-ext lis302dl
70: 137 s3c-uart0 s3c2440-uart
71: 99 s3c-uart0 s3c2440-uart
76: 0 s3c-uart2 s3c2440-uart
77: 20 s3c-uart2 s3c2440-uart
79: 0 s3c-adc s3c2410_action
80: 0 s3c-adc s3c2410_action

Err: 0

comment:4 follow-up: ↓ 5 Changed 5 years ago by werner

Hmm, there should be a line saying
BMI Get Target Info: Exit (ver: 0x20000059 type: 0x1)
so the WLAN drive did indeed fail to initialize the device, even
though the SDIO stack found it.

Was u-boot all you changed between the time it worked and the first time
it didn't or did you also change kernel, user space, etc. ?

comment:5 in reply to: ↑ 4 Changed 5 years ago by Zoup

Replying to werner:

Was u-boot all you changed between the time it worked and the first time
it didn't or did you also change kernel, user space, etc. ?

no BMI line at all , i have noticed that on old device .

i have upgraded Everything , since then i tried

Om2008-[8-9] , om2007 and Fdom , and their proper kernels , no change ( but on om2008-8 kernel i have noticed another ar6000_available line after these .

timeouts just appear when healthy one reports line you expecting .

module seems logically attached to the back of the board , i haven't noticed anything special but i don't know what to look for what exactly .

comment:6 Changed 5 years ago by Zoup

is hardware issue possible ?

comment:7 Changed 5 years ago by werner

Hardware is a possibility, yes. There's at least one case where the
problem is (was) almost certainly in the hardware:
https://docs.openmoko.org/trac/ticket/1983

comment:8 Changed 5 years ago by Zoup

well , all strange things are just happening to me .

well , how can i test ?

comment:9 Changed 5 years ago by werner

You seem to be unusually lucky indeed :-(

I'd suggest you install a specific u-boot, kernel, and rootfs, and try
booting with init=/bin/sh, then check with iwconfig.

If this still doesn't work, please post the URLs of the u-boot, kernel,
and rootfs you installed here (URLs to the long name, with date/revision,
so that I can still find the files the next day :-), and the dmesg output
of that run, and I'll try the same setup.

On the hardware side, you could try to remove all power sources, then
disconnect and reconnect the WLAN module. That would rule out the "module
wasn't properly connected and the contacts came apart during transport or
use" hypothesis.

comment:10 Changed 5 years ago by Zoup

everything is installed from
http://downloads.openmoko.org/releases/Om2008.9/
which is stable enough til end of history ;)

tried that with Wlan module , didn't helped .

comment:11 Changed 5 years ago by werner

Oh, 2008.9 is certainly "known to be good" for WLAN.
Seems that you indeed have a case of DoA, sorry :-(

I think our support team has already contacted you about a return.

comment:12 Changed 5 years ago by Zoup

yep , I'm in contact with them , thank you for your helps werner :)

comment:13 Changed 5 years ago by john_lee

  • Status changed from new to closed
  • Resolution set to wontfix

so, closed as wontfix because of the reasons above?

Note: See TracTickets for help on using tickets.