Ticket #2087 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

[Illume] The top bar and home icons are to small for fingure usage

Reported by: dolfje Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The icons and Illume top bar are to small for finger usage.

image: Testing image / 26 okt 08

Change History

comment:1 Changed 8 years ago by zecke

You might want to take this one up with raster/upstream. The button should only be visible in the "illume" profile which is the upstream profile where Openmoko has no influence on.

comment:2 Changed 8 years ago by newkirk

What 'button' are you referring to - the config spanner button?

The bug report doesn't mention that at all, although if installed and visible it is AFAIK the only way currently to enlarge the icons in the Launcher to a size that IS in fact convenient for finger tapping instead of being stylus dependent. I read the report as referring to Launcher icons as 'home icons', with which complaint I must agree.

The default settings with 2008.x currently ARE too small for convenient finger tapping of icons. I personally have frequent problems opening the top shelf in order to click 'close', and have trouble tapping 'close' with my finger instead of hitting the line above it and opening a running app, or hitting below it ON the running app and having the top shelf simply close.

j

comment:3 Changed 8 years ago by raster

it's then not upstream. definitely an om choice. the top-shelf gadgets sizes were reduced from the original sizes illume had by request from sean/will. i agree its small and hard to hit (i did a lot of testing initially and found to get something reliable for the top you need 64 pixels). illume upstream has larger defaults than 2008.x (56 for main and 48 for hidden) as well as the close button now being a big one along with a home and window list button. so upstream's design is already what you want i think :)

comment:4 Changed 8 years ago by dolfje

It's probably something wrong with the upgrade path I took.

I had a testing image from 13 okt and upgraded it yesterday and I had a small top bar and really small icons.

Today I tried a flash of the newest image and it gave me the big icons, I was used from 2008.9. (Also if I change the theme to illume by doing 'sed -i -e s,asu,illume, /etc/enlightenment/default_profile' it remains the big icons)

So sorry, I'm not able to reproduce this with the newest image.

comment:5 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • Resolution set to fixed

this is fixed by the theme update I did two days ago.

Note: See TracTickets for help on using tickets.