Ticket #209 (closed defect: community)

Opened 12 years ago

Last modified 10 years ago

u-boot DFU needs to block console access while in DFU mode

Reported by: laforge@… Owned by: michael
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

sine DFU does all kinds of strange things (such as doing device i/o) from USB
interrupt context, we should restrict interactive access to the bootloader while
dfu_state != DFU_STATE_appIDLE.

usbtty access is disabled anyway, since the interface and endpoint descriptors
for CDC ACM do not exist in DFU mode. After a successful DOWNLOAD, or to be
more precise: As soon as the USB host issues a USB reset, we switch back to
runtime mode (with usbtty) support anyway.

So this is really mainly about the serial port, which the standard user hasn't
access to anyway.

Change History

comment:1 Changed 11 years ago by willie_chen@…

  • Owner changed from laforge@… to michael@…

comment:2 Changed 10 years ago by roh

  • Owner changed from michael@… to michael

comment:3 Changed 10 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.