Ticket #2095 (closed defect: fixed)

Opened 9 years ago

Last modified 31 hours ago

Sound not found with qi bootloader

Reported by: newkirk Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: major Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

I've finally seen the pattern to a bug I've been having for weeks - If I'm using the qi bootloader (Thanks Andy, so far it's damned promising) then sound doesn't work. I try aplay from terminal and get errors that sound device doesn't exist. Reflash just bootloader back to uboot and sound returns. Reflash to qi and sound fails.

Both aplay amd mplayer report the following (this is mplayer's formatting, same messages from aplay):

[AO_ALSA] alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
[AO_ALSA] alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
[AO_ALSA] alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
[AO_ALSA] alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
[AO_ALSA] alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
[AO_ALSA] alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
[AO_ALSA] alsa-lib: conf.c:3982:(snd_config_expand) Evaluate error: No such device
[AO_ALSA] alsa-lib: pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM dmix
[AO_ALSA] Playback open error: No such device

dmesg under qi includes:

Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42 2007 UTC).
ASoC version 0.13.1
ALSA device list:

No soundcards found.

and:

snd: exports duplicate symbol snd_add_device_sysfs_file (owned by kernel)
wm8753: WM8753 Audio Codec 0.16
Alignment trap: hald-probe-volu (1197) PC=0x0000ce78 Instr=0xe59b300c Address=0xbed225aa FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbed225a6 FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce78 Instr=0xe59b300c Address=0xbed225ba FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbed225b6 FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce78 Instr=0xe59b300c Address=0xbed225ca FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbed225c6 FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce78 Instr=0xe59b300c Address=0xbed225da FSR 0x013
Alignment trap: hald-probe-volu (1197) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbed225d6 FSR 0x013

While under uboot there's a slight difference with:

Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42 2007 UTC).
ASoC version 0.13.1
ALSA device list:

No soundcards found.

and:

snd: exports duplicate symbol snd_add_device_sysfs_file (owned by kernel)
wm8753: WM8753 Audio Codec 0.16
asoc: WM8753 HiFi? <-> s3c24xx-i2s mapping ok
asoc: WM8753 Voice <-> Bluetooth mapping ok
Alignment trap: hald-probe-volu (1230) PC=0x0000ce78 Instr=0xe59b300c Address=0xbea845aa FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbea845a6 FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce78 Instr=0xe59b300c Address=0xbea845ba FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbea845b6 FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce78 Instr=0xe59b300c Address=0xbea845ca FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbea845c6 FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce78 Instr=0xe59b300c Address=0xbea845da FSR 0x013
Alignment trap: hald-probe-volu (1230) PC=0x0000ce94 Instr=0xe59b1008 Address=0xbea845d6 FSR 0x013

j

Change History

comment:1 Changed 9 years ago by newkirk

Sorry, meant to include that this affects SHR, FSO, Raster, and 2008.x. Everything I've tried.

j

comment:2 Changed 9 years ago by andy

The way that the alsa SoC stuff registers i2c things changed recently, stable-tracking uses the new way. I have seen it work and not work with qi on the 2.6.24 stuff. As soon as we fix the last few problems on stable-tracking we will transition to it as the new stable and hopefully this will be gone away.

comment:3 Changed 9 years ago by gromgull

(no comment - I just want to be cc'd)

comment:4 Changed 8 years ago by Leonti

I'm using 2.6.24 kernel with SHR and I have sound.
Is it me who is lucky or the problem is solved?
If so please confirm, so I(or anyone else) can edit wiki page.

Leonti

comment:5 Changed 8 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

Yes it's solved... Qi did not bring up the regulator used to power the codec.

comment:6 Changed 8 years ago by werner

Considering the 100mA envelope, shouldn't we leave regulators not
essential for booting off until the kernel decides it's safe to
turn them on ?

In the u-boot current-reduction work, keeping unused regulators off
made a significant difference, 40mA in total for LDO1, 2, 5, and 6.

See also u-boot commit 77ef5a9f920092fcebfe592607b7866ac36e3c8e

comment:7 Changed 8 years ago by andy

It's a good point, but since other things needed for Linux boot at < 100mA don't exist ye it's a job for another day... in the meanwhile "sound works with Qi".

comment:8 Changed 31 hours ago by Kennescoma

Clofazimine <a href=http://accutane.ccrpdc.com/buy-accutane.php>Buy Accutane</a> Amoxicillin And Dental Infection Side Effects Of Amoxicillin Clavulanate Potassium <a href=http://kama1.xyz/cheap-kamagra-generic.php>Cheap Kamagra Generic</a> Baclofene Farmaco Nizagara 100 <a href=http://cytotec.ccrpdc.com/cytotec-misoprostol.php>Cytotec Misoprostol</a> Viagra E Nitroderivati Order Viagra Usa Pharmacy <a href=http://cial1.xyz/cialis-5mg.php>Cialis 5mg</a> Baclofene Dose Maximale Viagra Prix <a href=http://cialis.ccrpdc.com/cialis-free-offer.php>Cialis Free Offer</a> Amoxicillin Treatment Of Chlamydia Propecia Pas Cher <a href=http://zoloft.ccrpdc.com/cheapest-zoloft.php>Cheapest Zoloft</a> Levitra Generika 10mg Rezeptfrei Dosage Amount Of Cephalexin For Dogs <a href=http://viag1.xyz/sildenafil-20mg.php>Sildenafil 20mg</a> Www Buycialisonlinecheap Zithromax Tooth Infection <a href=http://cial5mg.xyz/cialis-online-pharmacy.php>Cialis Online Pharmacy</a> Cephalexin Product Information where can i buy accutane yahoo <a href=http://zithromax.ccrpdc.com/how-to-get-zithromax.php>How To Get Zithromax</a> India Cialis Online Levitra 30 Mg <a href=http://zol1.xyz/buy-cheap-zoloft-pills.php>Buy Cheap Zoloft Pills</a> Order Orlistat Acquistare Levitra Originale <a href=http://zol1.xyz/cheap-zoloft-without-prescription.php>Cheap Zoloft Without Prescription</a> Amoxicillin Ibuprofen Amoxicillin 500 Dosage <a href=http://kama1.xyz/kamagra-price.php>Kamagra Price</a> Proscar 1mg Propecia Adverse Effect Of Amoxicillin <a href=http://viag1.xyz/buy-real-viagra-online.php>Buy Real Viagra Online</a> Come Comprare Cialis Receta Finasteride Comprar Propecia <a href=http://viag1.xyz/by-cheap-viagra.php>By Cheap Viagra</a> Buy Cialis 40mg Propecia Customer Specifications <a href=http://viag1.xyz/fast-delivery-viagra.php>Fast Delivery Viagra</a> Progesterone Medicine Where To Buy On Line Diabete E Cialis <a href=http://viag1.xyz/where-to-buy-viagra.php>Where To Buy Viagra</a> Dexamethasone No Prescription Buy Deltasone Without Prescription <a href=http://cial1.xyz/ordering-cialis-online.php>Ordering Cialis Online</a> Zithromax Liquid Dosage For Adults Priligy Forum 2013 <a href=http://cial1.xyz/cialis-online-no.php>Cialis Online No</a> Propecia Es Bueno Minoxidil 5 My Alli Canada <a href=http://cial1.xyz/cialis-usa.php>Cialis Usa</a> Buy Doxycycline Online Fish Cephalexin <a href=http://prednisone.ccrpdc.com/purchase-deltasone-40mg.php>Purchase Deltasone 40mg</a> Generic Cialis 100mg Cialis Efectos Secundarios <a href=http://viag1.xyz/viagra-alternative.php>Viagra Alternative</a> Acheter Cialis Usa Buy Fluoxetine <a href=http://cial5mg.xyz/buy-tadalafil-online.php>Buy Tadalafil Online</a> Levitra 5 Mg Valore Cialis 28 Compresse Da 5 Mg <a href=http://kama1.xyz/kamagra-pill.php>Kamagra Pill</a> Levaquin Express Delivery Levitra E Alcool <a href=http://viag1.xyz/purchase-viagra-usa.php>Purchase Viagra Usa</a> Ordinare Viagra Generico Priligy Cuanto Vale <a href=http://zol1.xyz/buy-sertraline-online-uk.php>Buy Sertraline Online Uk</a> Buy Generic Propranolol Online Cheap Plavix Canada <a href=http://cial5mg.xyz/tadalafil-tablets.php>Tadalafil Tablets</a> Viagra Pharmacy Prices Femilon <a href=http://viag1.xyz/generic-viagra.php>Generic Viagra</a> Tadalis Sx Soft Online Bestellen Propecia Coupon Code <a href=http://cial5mg.xyz/brand-cialis-online.php>Brand Cialis Online</a> Problemas De Propecia 247 Overnightpharmacy Com <a href=http://kama1.xyz/generic-kamagra-online.php>Generic Kamagra Online</a> Does Amoxicillin Treat Uti Cialis 5 Precio <a href=http://kama1.xyz/buy-cheap-generic-kamagra.php>Buy Cheap Generic Kamagra</a> Cialis Online 5 Mg Buy Tadacip Online Category Tadacip <a href=http://viag1.xyz/china-viagra-online.php>China Viagra Online</a> Zithromax 750 Mg Chlamydia Venta Cialis Hermosillo <a href=http://strattera.ccrpdc.com/order-strattera-online-usa.php>Order Strattera Online Usa</a> Lasix Sales Viagra Acostumbramiento <a href=http://antabuse.ccrpdc.com/antabuse-online-prices.php>Antabuse Online Prices</a> Is Priligy Any Good Venta Cialis Viagra <a href=http://kama1.xyz/cheap-kamagra-usa.php>Cheap Kamagra Usa</a> Lasix Mexico discount on line fedex shipping isotretinoin 10mg medication direct <a href=http://zol1.xyz/zoloft-online-buy.php>Zoloft Online Buy</a> Valtrex Mexico Fedex Isotretinoin Tablet Cheap <a href=http://kama1.xyz/generic-kamagra-cheap.php>Generic Kamagra Cheap</a> Baclofene Dose Seuil Worldwide Cheap Bentyl Buying Medication Free Shipping <a href=http://prednisone.ccrpdc.com/mail-order-deltasone.php>Mail Order Deltasone</a> Cialis Conditionnement Order Cheap Propecia <a href=http://zol1.xyz/buy-generic-zoloft-online.php>Buy Generic Zoloft Online</a> Cialis 4 Comprimes Generic Viagra Canada <a href=http://cial1.xyz/low-cost-cialis-online.php>Low Cost Cialis Online</a> Non Generic Viagra Online Pharmacy Viagra Pressione Arteriosa <a href=http://kama1.xyz/order-kamagra-onlines.php>Order Kamagra Onlines</a> What Does Amoxicillin Pills Look Like Cialis Uso <a href=http://cial5mg.xyz/buying-cialis-online.php>Buying Cialis Online</a> Viagra Sur Le Net Acheter Prix Cialis Montpellier <a href=http://zol1.xyz/implicane.php>Implicane</a> Propecia E Inseminacion Artificial Cialis Generico Senza Ricetta <a href=http://inderal.ccrpdc.com/buy-propranolol.php>Buy Propranolol</a> Will Lasix Show Up On A Drug Test Corlistat In Australia <a href=http://zol1.xyz/order-zoloft-without-script.php>Order Zoloft Without Script</a> Rx Canada Pharmacy Accutane Cialis Cerveza <a href=http://zol1.xyz/order-zoloft-in-usa.php>Order Zoloft In Usa</a> Pharmacie En Ligne Levitra Viagra Rezeptfrei Bestellen De <a href=http://cial1.xyz/buy-cheap-generic-cialis.php>Buy Cheap Generic Cialis</a> Zithromax 3 Day Dose SSS chief reforms spur benefit growth SSS to issue certifications for Taiwanbound OFWs Option to Sell Shares of Stocks Program New voluntary SSS retirement fund attracts PM savings from over enrollees Roxas City Capiz SSS President and Chief Executive Officer Emilio S. <a href=http://quickloannow24.com>easy loans</a> The money shop With a shortterm loan from The Money Shop you can borrow from to in increments of subject to our credit and affordability checks.Levitra For Sale <a href=http://kama1.xyz/how-much-is-kamagra.php>How Much Is Kamagra</a> Lasix Pay Online American Express Efectos De Cialis <a href=http://accutane.ccrpdc.com/accutane-generic.php>Accutane Generic</a> Sildenafil Gріс˜nstig Online Kaufen Propecia Pagina Oficial <a href=http://zithromax.ccrpdc.com/buy-zithromax-online-usa.php>Buy Zithromax Online Usa</a> Propecia Impasto

Note: See TracTickets for help on using tickets.