Ticket #21 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

sms function missing

Reported by: alex@… Owned by: sean_chiang@…
Priority: normal Milestone:
Component: gsmd Version: 2007
Severity: blocker Keywords:
Cc: laforge@…, buglog@…, jserv@…, sven-openmoko@…, balrogg@…, erin_yueh@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

We need sms support in gsmd.
1.Catch the sms events:
*incoming SMS received,
*sms memory full, can't receive
*sms sent
2.Recieve the incoming sms
3.Send the sms text to user specified number
4.Get sent report

Attachments

0001-Multiline-commands-support.-Miscellaneous-bugs.txt (13.2 KB) - added by balrogg@… 12 years ago.
Adds parser code for multiline commands.
0002-SMS-support-in-gsmd-and-in-libgsmd.txt (34.5 KB) - added by balrogg@… 12 years ago.
SMS sending and reception
0003-Incoming-SMS-events-and-dynamic-registration-of-unsolicited-responses.txt (16.9 KB) - added by balrogg@… 12 years ago.
Incoming SMS event and dynamic registration of unsolicited responses.
storage.patch (24.1 KB) - added by balrogg@… 12 years ago.
SMSC and Preferred Storage operations.
storage.2.patch (24.0 KB) - added by balrogg@… 12 years ago.
SMSC and Preferred Storage operations.
add_sms_mem_full_evt.patch (4.2 KB) - added by erin_yueh@… 12 years ago.
add an event 'SMS memory full'

Change History

comment:1 Changed 12 years ago by laforge@…

  • Owner changed from laforge@… to sean_chiang@…

Sean Chiang is supposed to be working on this.

comment:2 Changed 12 years ago by laforge@…

  • Severity changed from blocker to critical

comment:3 Changed 12 years ago by laforge@…

  • Cc laforge@… added

* Bug 99 has been marked as a duplicate of this bug. *

comment:4 Changed 12 years ago by laforge@…

  • blocked set to 65

comment:5 Changed 12 years ago by alex@…

  • Priority changed from low to normal
  • Severity changed from critical to blocker
  • Milestone set to Phase 1

comment:6 Changed 12 years ago by mickey@…

What's the status on this?

comment:7 Changed 12 years ago by alex@…

sms support has not been supported in libgsmd yet.

comment:8 Changed 12 years ago by laforge@…

I'm reviewing Seans' changes/modifications for SMS support since yesterday.
Expect it to be integrated by tomorrow.

comment:9 Changed 12 years ago by sven-openmoko@…

  • Cc sven-openmoko@… added

Changed 12 years ago by balrogg@…

Adds parser code for multiline commands.

Changed 12 years ago by balrogg@…

SMS sending and reception

comment:10 Changed 12 years ago by balrogg@…

  • Cc balrogg@… added

Changed 12 years ago by balrogg@…

Incoming SMS event and dynamic registration of unsolicited responses.

comment:11 Changed 12 years ago by jserv@…

  • Cc jserv.tw@… added

Changed 12 years ago by balrogg@…

SMSC and Preferred Storage operations.

comment:12 Changed 12 years ago by balrogg@…

  • attachments.isobsolete changed from 0 to 1

comment:13 Changed 12 years ago by f.koester@…

  • Severity changed from blocker to trivial

When will this patches be integrated into the openmoko-trunk? Or are they
already?
I am currently not able to send sms with the libgsmd-tool, getting
segmentation-faults.

comment:14 Changed 12 years ago by f.koester@…

  • Severity changed from trivial to blocker

changed severity inadvertently

Changed 12 years ago by erin_yueh@…

add an event 'SMS memory full'

comment:15 Changed 12 years ago by erin_yueh@…

  • Cc erin_yueh@… added

comment:16 Changed 12 years ago by tick@…

  • Status changed from new to closed
  • Resolution set to fixed

I want to close this issue for there are two patches commited.

r3199 | jserv | 2007-10-17 12:30:24 +0800 (三, 17 10月 2007) | 10 lines

http://bugzilla.openmoko.org/cgi-bin/bugzilla/show_bug.cgi?id=834

From: Kristian Mueller <kristian@…>

Subject: [PATCH] libgsmd-tool does not allow sms with more than one word

libgsmd-tool only allows for command strings without spaces.

SMS messages with more than one word will be parsed as multible commands.

The patch introduces SMS message text in bracket and fixes a NULL pointer

reference on mailformed "ss" commands.


r3200 | jserv | 2007-10-17 14:10:26 +0800 (三, 17 10月 2007) | 12 lines

SMS status report

From: Erin Yueh <erin_yueh@…>

Subject: [PATCH] SMS status report

I made a patch for SMS status report. It can change SMS-Submit messages

and ask for a status report. When the destination address receives our

message, the service center will send a SMS-STATUS-REPORT to us. We can

tell what messages we sent by TP-MR (message reference number) value and

can know the sending result by TP-ST (Status) value from status report

messages.

comment:17 Changed 11 years ago by anonymous

  • Milestone Phase 1 deleted

Milestone Phase 1 deleted

Note: See TracTickets for help on using tickets.