Ticket #2115 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

White Screen of Death (even without suspend)

Reported by: RuiSeabra Owned by: openmoko-kernel
Priority: normal Milestone: FSO
Component: kernel Version: GTA02v5
Severity: major Keywords: WSoD white screen death idle fso gta02v5
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

I've noticed this on the dailies, but now I installed FSO Milestone 4 and it happens as well.

Because the WSoD on suspend still isn't solved, I disable suspending.

I count on at least screen dimming to save some energy but... now even dimming the screen causes the WSoD after some time (maybe the suspected ten minutes or so).

Change History

comment:1 Changed 6 years ago by alphaone

This is really strange, does it also happen with milestone4?

In any case I suspect this is not really an FSO, but a kernel problem.

comment:2 Changed 6 years ago by RuiSeabra

I'm reporting it with FSO M4 installed (1st phrase). :)

It also happened with the Om2008.11.x dailies.

I believe it's a graphic card's driver issue.

comment:3 Changed 6 years ago by theseer105

I can confirm that. I also see this issue if the phone is suspended or the screen ist turned off. My experience is that the problem appears if the phone has been running for about 8 hours, no matter if it has been running all the time or if it has been suspended.

comment:4 Changed 6 years ago by nicolas.dufresne

I'm convince this is a duplicate of #1841. The bug is triggered sometimes when resuming the jbt driver. I confirm that disabling the jbt suspend removes the bug (no an actual fix).

comment:5 Changed 6 years ago by RuiSeabra

There's a patch and a test kernel at #1841 which so far looks like it solved this problem for me.

This (#2115) bug doesn't happen with that kernel. So attached patch would solve many problems in one.

comment:6 Changed 6 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

I believe this is solved in both stable and andy-tracking for some time.

Note: See TracTickets for help on using tickets.