Ticket #2121 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

[audio] new alsa state for A7

Reported by: wendy_hung Owned by: zecke
Priority: high Milestone:
Component: Audio Version:
Severity: critical Keywords:
Cc: testing@…, joerg@…, marek@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Here is the new alsa state for GTA02 A7.

The change inside is:
control.4 (bypass) value.0 127 / value.1 127
control.6 (speaker) value.0 7 / value.1 7

control.5 (Mono side tone) value 110
control.12 (Mono) value 7
control.48 (Mic2) value 3

This change can volume up the mic and receiver's volume.
Please check the attached file.

Attachments

gsmhandset.state.new (16.9 KB) - added by wendy_hung 5 years ago.
gsmhandset-a7.state (16.9 KB) - added by matt_hsu 5 years ago.

Change History

Changed 5 years ago by wendy_hung

Changed 5 years ago by matt_hsu

comment:1 Changed 5 years ago by matt_hsu

  • Status changed from new to closed
  • Component changed from unknown to Audio
  • Resolution set to fixed

After testing the *real* A7 from factory, we should have the following change for better audio quality.

  • enlarge GSM output volume with below AT command.

at+clvl=230

  • reduce the gain of MIC to avoid echo issue by changing alsa file.

see gsmhandset-a7.state file

comment:2 Changed 5 years ago by joerg

Echo has to be controlled by proper AT%Nxxxx settings. It can't be controlled by reducing volume and senitivity as you won't get sufficient audio levels when echo stops.

comment:3 Changed 5 years ago by alphaone

Joerg said:
<DocScrutinizer?> http://docs.openmoko.org/trac/attachment/ticket/2121/gsmhandset.state.new IS THE ONE *REAL* STATEFILE

I agree. gsmhandset-a7.state is wrong
Setting Mic2 Capture Volume to 0 in order to reduce echo is NOT the right solution.
Please use gsmhandset.state.new

comment:4 Changed 5 years ago by TimoJyrinki

I believe gsmhandset.state.new is not completely correct. See for example http://lists.openmoko.org/pipermail/community/2009-July/050609.html

The statefile has all mic settings completely maxed out, which seems to turn into severe audio problems. In that thread I suggested my tweaked gsmhandset.state, which has speaker volume set to 115 and mono playback volume set to 100. With those settings, I don't have problems and neither seem to have others. The speaker volume might be left at 127, I just lowered it ouf of habit because of the earlier echo problems, but regarding the mono playback I received negative feedback still at level 105 from a person so lowered it to 100.

Using buzz-fixed Freerunners. At least hopefully more people will test this, but it sounds sane not to max out everything (Mic2 3, mono sidetone 7, mono playback 127).

comment:5 Changed 4 years ago by joerg

to make clear once more:
There are different devices out there which will need different settings for mic and earpiece volume to fully accommodate to user's preferences.
There's exactly TWO controls to do this though, in mixer:
#5 for mic
#4 for earpiece

There's no point in fiddling with any of the other mixer controls to improve audio quality!

Please refer to http://wiki.openmoko.org/wiki/Neo_Freerunner_audio_subsystem#Alsamixer_channel_controls
as well

/jOERG

Note: See TracTickets for help on using tickets.