Ticket #2127 (closed defect: community)

Opened 5 years ago

Last modified 5 years ago

[python-bindings] upgrade path from 2008.9 broken

Reported by: marek Owned by: john_lee
Priority: normal Milestone:
Component: Distro Version:
Severity: normal Keywords: Om2008.11
Cc: ivar.mossin@…, Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Coming from 2008.9 by upgrading the python binding are not upgraded successfully. Hence, you can't start settings. A fresh install of the latest daily build fixes it. See #2088 for details.

Attachments

list_installed (50.4 KB) - added by BillK 5 years ago.
List_installed

Change History

comment:1 Changed 5 years ago by john_lee

  • Owner changed from openmoko-devel to julian_chu
  • Component changed from unknown to Distro

Please provide more details. Can I reproduce this by

  • Install om2008.9
  • switch to testing repo
  • opkg update
  • opkg upgrade

and what's the error message?

If this is about #2088, it should already be solved by

commit ae66a5a6ace177f0624397a43b98eb39379889f5
Author: John Lee <john_lee@…>
Date: Tue Oct 28 16:07:44 2008 +0800

python-e*: increase PR of python-efl bindings to relfect the EFL ABI change.

comment:2 Changed 5 years ago by marek

I know that the bug itself was fixed. I'm picking it up here because it was reported (again) on the community mailing list (subject: [2008.x] Settings app not working). You will find 2 threads with the same topic (including an error message). Its the same error message provided in #2088

I think your reproduction steps are the way to go.

comment:3 Changed 5 years ago by john_lee

  • Cc ivar.mossin@… added
  • Status changed from new to in_testing

etk changed from its own git to enlightenment svn. upstream made new bb but didn't change PE so upgrade won't use the latest version. commited, please test.

comment:4 Changed 5 years ago by pooze

I just reproduced this (again) with the exact same result. Same stable image, same upgrade procedure, same error and same backtrace.

While at it, how do you "reproduce" a working upgrade from stable image?

comment:5 Changed 5 years ago by marek

  • Owner changed from julian_chu to john_lee
  • Status changed from in_testing to assigned

I think the problem still exists (see #2088). The information provided there might help.

comment:6 Changed 5 years ago by john_lee

  • Status changed from assigned to in_testing

it's there in the repository:

http://downloads.openmoko.org/repository/testing/armv4t/python-etk_0.3.0+svnr36882-r0.01_armv4t.opk

so please check if there is a line
python-etk - 1:0.3.0+svnr36882-r0.01 -
in the output of 'opkg list_installed'

Marek, if you think it still exists, could you please provide how to reproduce? Because I have already seen the new package from my side.

comment:7 Changed 5 years ago by marek

Some hours ago a "new" bug report regarding this issue came in here: #2088
The reporter says that the package is there but obviously has some trouble installing it. I thought you can help him.

Changed 5 years ago by BillK

List_installed

comment:8 Changed 5 years ago by BillK

I am still seeing this problem with a 2008.9 upgrade. Originally had the wrong python-etk - removed and installed (twice now!)

full list installed attached and:

~#opkg list_installed |grep etk
etk-theme-ninja - 0.0.1+svnr5-r1 -
libetk-engines-evas - 2:0.1.0.043+svnr36882-r2.05 -
libetk-engines-fb - 2:0.1.0.043+svnr36882-r2.05 -
libetk-engines-software-x11 - 2:0.1.0.043+svnr36882-r2.05 -
libetk-engines-software-x11-16 - 2:0.1.0.043+svnr36882-r2.05 -
libetk-engines-x11 - 2:0.1.0.043+svnr36882-r2.05 -
libetk-themes - 2:0.1.0.043+svnr36882-r2.05 -
libetk1 - 2:0.1.0.043+svnr36882-r2.05 -
python-etk - 2:0.3.0+svnr36882-r0.01 -
~#

comment:9 Changed 5 years ago by BillK

As requested by John Lee on the community list:

Had to kill the running exposure.py first. i tried the force-depends remove in bug 2088, as well as reinstalling all the ecore packages already installed.

~#killall exposure.py
~#killall exposure.py
killall: exposure.py: no process killed
~#
~#exposure.py -f run
[Etk-Warning] (ecore_evas_x11.c:190 - _engine_init()):
Ecore_X initialization failed!

[Etk-Warning] (etk_engine.c:221 - etk_engine_load()):
Etk can not initialize the requested engine!

Segmentation fault
~#

comment:10 Changed 5 years ago by john_lee

I think you're not using the software_16 engine. I think most of the om2008 apps are developed based on this assumption.

comment:11 Changed 5 years ago by BillK

Yes, because I am using illume theme I am subject to the segfaults, so it was reccomended to switch to softeware engine.

BillK

comment:12 Changed 5 years ago by john_lee

Yeah, I know that, but the only tested combination is the asu theme plus software_16 because they are in Om2008. I'll try to either fix the engine or these applications in my own time.

comment:13 Changed 5 years ago by BillK

Confirmed :(

I just flashed todays testing (12Dec) and yes, change the "engine" and "Settings" dies on startup.

Also, it seems that exposure.py may also be involved in setting the GSM icon on the top shelf so thats why there is no GSM level in illume with software engine.

comment:14 Changed 5 years ago by Nytowl

  • Status changed from in_testing to closed
  • Resolution set to community
Note: See TracTickets for help on using tickets.