Ticket #2136 (new defect)

Opened 9 years ago

Last modified 9 years ago

Freerunner QVGA portrait mode wrong colors

Reported by: Vladimir.Koutny Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version: Om2008.9-dev
Severity: normal Keywords:
Cc: vlado@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

When switching to QVGA mode using "xrandr --mode 240x320" the display is too bright - all colors are brighter than they should be and there are ligher/darker bars around most onscreen elements. Framebuffer content is correct.

It is possible to fix this by rotating the screen left/right and then back to normal (via xrandr again). This fix is then 'valid' until next xglamo restart - even if you change to VGA and back.

Some pictures (change in color is not very clear but the light bars are): http://people.ksp.sk/~vlado/moko/qvga.html

Kernel+Rootfs: today's 2008.9 (or my own build, doesn't matter):
Om2008.9-gta02-20081106.uImage.bin
Om2008.9-gta02-20081117.rootfs.jffs2

Change History

comment:1 Changed 9 years ago by Leonti

From http://wiki.openmoko.org/wiki/Video_Player:

    * 240x320 mode has some quirks:
          o The gamma/brightness/contrast is weird. Encoding adjustments into the media is a workaround.
          o Vertical banding (as seen in landscape position) is quite noticeable. 

I think this is the same bug.
Leonti

Note: See TracTickets for help on using tickets.