Ticket #2140 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Should use different volumes for ringtone and receiver

Reported by: john_lee Owned by: tick
Priority: normal Milestone:
Component: Qtopia Version: Om2008.9-dev
Severity: normal Keywords: Om2008.11
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: yes PatchReviewResult: positive
Reproducible: always

Description

Tick made a volume control for #1489, but it's actually the same volume level used by ringtone. So if we set the phone to silent or vibrate and pick up a phone call, the receiver volume will become 0 (mute). That means you can't hear the caller's voice.

Attachments

0001--QPhoneProfile-add-support-to-callVolume.patch (4.9 KB) - added by Treviño 10 years ago.
callVolume support for QPhoneProfile
0002--CallScreen-Use-callVolume-instead-of-volume.patch (1.1 KB) - added by Treviño 10 years ago.
Fix callscreen defalt value
0003--PhoneProfile-Add-CallVolume-to-configuration-files.patch (1.6 KB) - added by Treviño 10 years ago.
Update the qtopia defalult settings

Change History

comment:1 Changed 10 years ago by tick

  • Status changed from new to accepted

comment:2 Changed 10 years ago by Treviño

Ok, I've fixed is creating a new option in QProfileManager called CallVolume?. Now the qtopia call slider use this value as default while calling.

I guess that also the OpenEmbedded? configuration file for Qtopia (PhoneProfile?.conf) should include the "CallVolume?" option by default not to make users call with no voice at all.

Patches coming...

Changed 10 years ago by Treviño

callVolume support for QPhoneProfile

Changed 10 years ago by Treviño

Fix callscreen defalt value

Changed 10 years ago by Treviño

Update the qtopia defalult settings

comment:3 Changed 10 years ago by tick

  • PatchReviewResult set to positive
  • HasPatchForReview set

Cool...
Thank you very much
Patch looks good to me.
I will commit them after passing test.

comment:5 Changed 10 years ago by tick

  • Status changed from accepted to in_testing

comment:6 Changed 10 years ago by Treviño

As said before the issue won't be fixed completely until you upgrade the file at:
http://git.openmoko.org/?p=openmoko.git;a=blob;f=packages/qtopia-phone/openmoko-phoneprofile-data/PhoneProfile.conf;h=c22328febaff63e5a72c18dce92254773fa69ab0;hb=HEAD (packages/qtopia-phone/openmoko-phoneprofile-data/PhoneProfile.conf).

It should be upgraded adding CallVolume? with something like (I've set it to 3, since 4 is too much from my tests on a GTA02v5):

--- PhoneProfile.conf.old	2008-11-29 02:16:40.000000000 +0100
+++ PhoneProfile.conf	2008-11-29 02:17:09.000000000 +0100
@@ -10,6 +10,7 @@
 System = 1
 Vibrate = 1
 Volume = 3
+CallVolume = 3
 [Profile 2]
 AutoAnswer = 0
 CallAlert = 0
@@ -22,6 +23,7 @@
 System = 1
 Vibrate = 0
 Volume = 0
+CallVolume = 3
 [Profile 3]
 AutoAnswer = 0
 CallAlert = 0
@@ -34,6 +36,7 @@
 System = 1
 Vibrate = 1
 Volume = 0
+CallVolume = 3
 [Profile 4]
 AutoAnswer = 0
 CallAlert = 2
@@ -46,6 +49,7 @@
 System = 1
 Vibrate = 0
 Volume = 3
+CallVolume = 3
 [Profiles]
 Profiles = "1,2,3,4"
 Selected = 1
}}

comment:7 Changed 10 years ago by john_lee

It seems you fixed the wrong place , Tick. :p Please update the file in OE as well.

comment:8 Changed 10 years ago by tick

Orz...

Done

comment:9 Changed 10 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

tested with image below:
kernel:testing-om-gta02-20081210.uImage.bin
rootfs:openmoko-testing-om-gta02.rootfs.jffs2 (20081210)

Check it's fixed, thanks!

Note: See TracTickets for help on using tickets.