Ticket #2148 (closed defect: community)

Opened 10 years ago

Last modified 10 years ago

[2008.11 testing] Settings application fails to open

Reported by: iknowjoseph Owned by: Nytowl
Priority: normal Milestone:
Component: Distro Version: Om2008.9-dev
Severity: normal Keywords:
Cc: ray_chao@…, julian_chu@…, iknowjoseph@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Flashed a fresh 2008.9 and updated to testing as per John Lee's instructions. The settings application fails to open when selected, which makes setting the suspend time impossible, which has the same effect on SSH'ing into the phone.

Attachments

testing_installed.txt (45.1 KB) - added by iknowjoseph 10 years ago.
opkg list_installed

Change History

comment:1 Changed 10 years ago by john_lee

please provide the output of "opkg list_installed" , thanks for reporting.

Changed 10 years ago by iknowjoseph

opkg list_installed

comment:2 Changed 10 years ago by iknowjoseph

As attached, thanks John.

comment:3 Changed 10 years ago by gromgull

This is surely a duplicate of https://docs.openmoko.org/trac/ticket/2088, and the real problem is the upgrade path: https://docs.openmoko.org/trac/ticket/2127 Or?

comment:4 Changed 10 years ago by john_lee

  • Owner changed from openmoko-devel to julian_chu
  • Cc ray_chao@…, julian_chu@… added
  • Component changed from unknown to Distro

your attachment shows

python-etk - git-r0.02 -

while it should really be

python-etk - 1:0.3.0+svnr36882-r0.01 -

It turns out there are two problems here:

  1. There is already PE="1" in asu.stable, so it has to be PE="2" in om.dev to exceed it.
  2. The Packages file in http://downloads.openmoko.org/repository/testing/armv4t/ shows the version of python-etk to be 0.3.0+svn36882-r0.01, the "1:" is missing. Julian, please work with Ray to find out what's wrong on the build server.

iknowjoseph:

opkg -force-depends remove python-etk
opkg install python-etk

this will solve your problem.

comment:5 Changed 10 years ago by iknowjoseph

That worked great, thanks John.

comment:6 Changed 10 years ago by julian_chu

  • Status changed from new to accepted

There is a strange problem in the configure file of building system. John and me found that and fixed it. Just wait and see if it is fixed or not tomorrow.

comment:7 Changed 10 years ago by julian_chu

  • Status changed from accepted to in_testing

This is the latest content of Packages.

Package: python-etk
Version: 2:0.3.0+svnr36882-r0.01
Depends: python-evas, python-ecore, python-edje, python-numeric (skip)

It got the correct value (PE=2) as we hoped, thanks God.

comment:8 Changed 10 years ago by wendy_hung

  • Summary changed from [2009.11 testing] Settings application fails to open to [2008.11 testing] Settings application fails to open

change the summary because we don't have Om2009 yet, in case we got confuse.

comment:9 Changed 10 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:10 Changed 10 years ago by Nytowl

  • Status changed from in_testing to closed
  • Resolution set to community

This seems to have been solved. If not it is now a community issue.

Note: See TracTickets for help on using tickets.