Ticket #2157 (closed defect: community)

Opened 10 years ago

Last modified 10 years ago

SMS messages are not received untill reboot/restart of X

Reported by: BillK Owned by: Nytowl
Priority: normal Milestone:
Component: Distro Version: Om2008.9-dev
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

2008.9 updated to testing using the update process posted to community by John Lee (problem was the same before update, was expecting it to be fixed):

Using illume theme,
8gb SanDisk? SD card with clock reduced (10000000)
p1=ext2, p2=ext3 and p3 is a 128M swap
Vodaphone 128K SIM
GSM fw flashed to moko10b2
(No difference to this problem, but it no longer requires up to 10 full reboots before PIN dialog would appear, so its fixed something!)

On Sun, 2008-11-30 at 19:50 +0800, John Lee wrote:

Dear Community,

As Sushama (our new testing team member) indicated in
http://lists.openmoko.org/pipermail/devel/2008-November/003493.html ,
we won't have a release in Nov. Currently the testing team is going

...

Ive been using this for a couple of days now and have some more items:

SMS messages are still being held up. If the phone is suspended, it
will wake but never indicate an SMS has been received. They only show
up when rebooting the phone, or mostly on restarting the xserver. There
are a few bugs on this like 1766, but thats not exactly the same and was
supposed to be fixed in testing - would this fix come in as part of the
upgrade?

This doesn't seem like #1766, and I've just received a sms in
suspend... Could you file a ticket? Please attach the following if
possible:

  • upgrade from Om2008.9 or flashed daily image ?
  • output of 'opkg list_installed'
  • logread
  • the modified qtopia config file, if any.

Attached file "logread" is a clean boot, PIN dialog, registered, then suspended.
Sent a test message from another phone, FR woke up but no other indication
"/etc/init.d/xserver-nodm restart"
Entered PIN
SMS receive pop-up and sound ~1minute later.

Attachments

89qtopia (663 bytes) - added by BillK 10 years ago.
Only change is "export QTOPIA_NO_VIRTUAL_KEYBOARD=1"
list_installed (47.4 KB) - added by BillK 10 years ago.
logread (63.2 KB) - added by BillK 10 years ago.

Change History

Changed 10 years ago by BillK

Only change is "export QTOPIA_NO_VIRTUAL_KEYBOARD=1"

Changed 10 years ago by BillK

Changed 10 years ago by BillK

comment:1 Changed 10 years ago by Weiss

I'm getting some very similar-sounding symptoms, so you're not the only one. What happens if you try to make a call (incoming or outgoing) a long time (and a few suspend cycles) after booting?

For me, incoming calls go straight to voicemail (even with the Freerunner switched on and apparently registered), and outgoing calls show "Disconnected" straight away. Do your symptoms match those? To me, it looks like the GSM unit is "silently" losing registration, so nothing gets sent either way until you force a re-registration by restarting X.

I have also done the GSM firmware upgrade to gsm_ac_gp_fd_pu_em_cph_ds_vc_cal35_ri_36_amd8_ts0-Moko10. The problem may have started since the upgrade, but I couldn't swear to it.

comment:2 Changed 10 years ago by BillK

Doesnt sound similar - I have no problems with calls - either when awake or suspended. No reports of missed calls etc. Its only SMS, mostly when suspended but occasionally when awake. Get maybe 2 voice calls a week, but 2-3 SMS's a day - well used to, people have stopped sending saying I never reply/get them in time :(

There was another bug that sounded similar to your symptoms though, from the early ASU days I think.

BillK

comment:3 Changed 10 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:4 Changed 10 years ago by Nytowl

  • Status changed from new to closed
  • Resolution set to community
Note: See TracTickets for help on using tickets.