Ticket #2162 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Changing screen modes (QVGA) corrupted in stable-tracking

Reported by: TimoJyrinki Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Using 2008.9 + self-compiled kernel f2b6b0b0b2d235457e0c69cfdbf4f66a12dc2c4e (stable-tracking). No problem if using stable kernel.

Starting eg. Doom (rotated QVGA) results in a near-white screen, where one can see that it's actually VGA resolution with four identical QVGA rectangles with something that resembles the actual Doom play screen. See attached screenshot.

This might be related to the WSOD bug #1841 and fixes done with it, since before the latest commit I got similarly corrupted screen even when just rotating the screen (Pingus, VGA rotated), but now with the cleaner WSOD fix Pingus seems to reliably start but the QVGA screen modes stay as a problem.

I mentioned in #1841 that after the cleanup patch I got different kind of screen, but now I'm again getting the original that the photo is about. The another kind of corruption had more darker appearance with stripes, and no clear indication about Doom being running on the screen.

Attachments

stable-tracking-qvga.jpg (244.3 KB) - added by TimoJyrinki 6 years ago.

Change History

Changed 6 years ago by TimoJyrinki

comment:1 Changed 6 years ago by TimoJyrinki

Have to note I naturally get exactly same kind of screen by just running xrandr -s 320x240.

comment:2 Changed 6 years ago by nicolas.dufresne

We get similar issue using xrandr -o <orientation> multiple time. I confirm this is a regression between the new kernel and the stable one.

comment:3 Changed 6 years ago by andy

Is either of these problems still happening on current andy-tracking or stable kernels? In particular the xrandr one can be helped by this:

http://git.openmoko.org/?p=kernel.git;a=commitdiff;h=8e07543735b1b180ff45993f0e3cc82dad8142ea

comment:4 follow-up: ↓ 5 Changed 6 years ago by TimoJyrinki

Rotation seems to be fixed (though I haven't stress-tested it), but changing to QVGA is still broken. You should be able to reproduce the problem simply by doing xrandr -s 240x320 on the command line. If not, let me know, it's been some time I've been able to play OpenDoom? :)

comment:5 in reply to: ↑ 4 Changed 6 years ago by arhuaco

With "xrandr -s 240x320" I got a white screen with yellow points :-/

comment:6 Changed 6 years ago by andy

Balaji knows how to fix half of this already anyway, he says XGlamo is using the wrong /sys path. On current kernels it needs to be

/sys/bus/spi/devices/spi2.0/state

If you do the xrandr, and on a terminal do

export DISPLAY=:0 ; echo qvga-normal > /sys/bus/spi/devices/spi2.0/state

it will correct the bad display into good QVGA.

The remaining problem is after framebuffer blanking, you'll get a WSOD.

comment:7 Changed 5 years ago by PaulFertser

  • Status changed from new to closed
  • Resolution set to fixed

QVGA works for quite some time already.

Note: See TracTickets for help on using tickets.