Ticket #2179 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

GTA02 ASoC capture kernel oops

Reported by: laforge Owned by: openmoko-kernel
Priority: normal Milestone: FSO
Component: kernel Version: current svn head
Severity: normal Keywords: asoc capture
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

When trying to use the GTA02 to capture PCM data, the stable-tracking kernel oopses.

The following steps can be used to reproduce this:

$ wget http://wildsau.enemy.org/~moko/voice-recording.state
$ alsactl -f voice-recording.state restore
$ arecord -v -f cd -c 2 foo.wav
Segmentation fault

I will attach the kernel oops

Attachments

asoc-crash.txt (4.9 KB) - added by laforge 5 years ago.
dmesg output of asoc kernel oops
voice-recording.state (16.9 KB) - added by laforge 5 years ago.
the voice-recording.state file used

Change History

Changed 5 years ago by laforge

dmesg output of asoc kernel oops

Changed 5 years ago by laforge

the voice-recording.state file used

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 5 years ago by laforge

there seem to be actually two independent problems

1) the fact that there are no matching rates " WM8753 HiFi? <-> s3c24xx-i2s No matching rates"

2) the fact that this causes a kernel oops in the
neo1973_gta02_hifi_hw_free() function. This is caused by dai_ops.set_pll() == NULL, which in turn seems to be caused by the fact that snd_pcm_open_substream() is not finished (due to the 'no matching rate' bug above) and calls snd_pcm_release_substream() for a not fully opened substream.

comment:2 in reply to: ↑ 1 Changed 5 years ago by erl

I think this is a dupe of bug #2073.

It would be great if someone could raise the priority of this bug. It would be useful to debug microphone problems, hack VoIP, speech recognition and general audio recording stuff.

comment:3 Changed 5 years ago by andy

I pinged Graeme about it yesterday if he's not able to look at it somebody else will.

comment:4 Changed 5 years ago by marek

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #2073

comment:5 Changed 4 years ago by joerg

  • Status changed from closed to reopened
  • Resolution duplicate deleted

made 2073 a dup of this

comment:6 Changed 4 years ago by joerg

  • Status changed from reopened to closed
  • Resolution set to duplicate

an oops. closed again. sorry for the noise

Note: See TracTickets for help on using tickets.