Ticket #2193 (closed defect: community)

Opened 5 years ago

Last modified 5 years ago

Pidgin segfaults right after startup

Reported by: MMlosh Owned by: Nytowl
Priority: normal Milestone: Om2008.12
Component: Distro Version:
Severity: blocker Keywords: pidgin
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Pidgin from default repositories in default OM/ASU 2008.12 (in internal memory, started with both Qi and NOR U-Boot)

Device was right after reflash and reboot, no configuration was changed. Only "opkg update" and "opkg install pidgin".

Results of "pidgin -d 2>pidginfail_stderr.txt >pidginfail_stdout.txt" are atached.

note: there is no icon for pidgin on Homescreen...

Attachments

pidginfail_stderr.txt (696 bytes) - added by MMlosh 5 years ago.
Pidgin -d output on STDERR
pidginfail_stdout.txt (3.6 KB) - added by MMlosh 5 years ago.
Pidgin -d output on STDOUT

Change History

Changed 5 years ago by MMlosh

Pidgin -d output on STDERR

Changed 5 years ago by MMlosh

Pidgin -d output on STDOUT

comment:1 Changed 5 years ago by MMlosh

Without protocol plugin is crash faster (less plugins found and probed)

When started without "-d" (debug mode), nothing appears on STDOUT, only that error message from STDERR.

comment:2 follow-up: ↓ 3 Changed 5 years ago by Mike Kalagan

There are at least two separate packages: pidgin and pidgin-data. Both of them must be installed. Maybe you need pidgin-doc too.

comment:3 in reply to: ↑ 2 Changed 5 years ago by MMlosh

Replying to Mike Kalagan:

There are at least two separate packages: pidgin and pidgin-data. Both of them must be installed. Maybe you need pidgin-doc too.

Thanks a lot... pidgin-data was missing (=>It's only bug in dependency)

I was not expecting existence of pidgin-data, because it was merged with pidgin in other version (no idea which...)

comment:4 Changed 5 years ago by husku

Im running 2008.12 with testing repos, all up2date. when i start pidgin and try to create new account, the dialog does not display keyboard for password field.

comment:5 Changed 5 years ago by MMlosh

husku: Yes, that's normal, because only normal textboxes were hooked to call for keyboard.

I've added "qwerty button" (instructions here: http://wiki.openmoko.org/wiki/Keyboard_Toggle#Method_2 ; to switch to illume=Raster's keyboard follow here: http://wiki.openmoko.org/wiki/Enlightenment_.cfg)

BTW: Husku: Your comment describes different defect or no defect at all !!!

comment:6 Changed 5 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:7 Changed 5 years ago by Nytowl

  • Status changed from new to closed
  • Resolution set to community

This is a problem with the OE pidgin recipe. Please send the bug upstrream

Note: See TracTickets for help on using tickets.