Ticket #2198 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

Provide more intelligent pakcage dependancies in opkg

Reported by: pander Owned by: Nytowl
Priority: normal Milestone:
Component: Distro Version: unspecified
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Please provide more intelligent package dependancies in opkg. E.g. an inclusive OR. a package that depends on illume will not get installed when shr-illume is installed.

Opkg should support something like
Depends: illume|shr-illume

The ',' (comma) will have higher priority than the '|' (or) so the Depends line can be exteded futher like before.

Change History

comment:1 Changed 10 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:2 Changed 10 years ago by pander

Please, also consider excluding/blocking dependencies, i.e. when package x would like to be installed, it is not possible as long as package y is installed. See http://trac.shr-project.org/trac/ticket/334 for example.

comment:3 Changed 10 years ago by Nytowl

  • Status changed from new to closed
  • Resolution set to worksforme

The first problem is a problem with the shr recipe. It should state that it provides illume

opkg can already keep one package from being installed when there is some type of overlap.

Note: See TracTickets for help on using tickets.