Ticket #2211 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Windows instant reboot while connecting Freerunner on USB

Reported by: psonek Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I cant get Freerunner working on WinXP with 2.6.28 kernels. Windows just instantly reboot - they dont provide any more details.

I am using the Neo1973.inf from wiki. This was tested with todays SHR unstable. With older kernels (2.6.24) i dont have this problem.

The possible cause can be in g_ether module, because when i do rmmod g_ether Windows dont reset anymore, but USB networking and charging battery does not work. Any ideas?

Change History

comment:1 Changed 6 years ago by cedric.berger

this was just discussed on kernel mailing list,
and patches should have been merged now...

http://lists.openmoko.org/nabble.html#nabble-td2183476%7Ca2184241

On Tue, Jan 20, 2009 at 00:06, Andy Green <andy@…> wrote:

On Mon, Jan 19, 2009 at 23:37, Paul Fertser <fercerpav@…> wrote:

| Hi,
|
| I confirm it's a kernel issue. Windows RNDIS is definetely buggy, but
| the kernel driver is wrong also. See
| http://article.gmane.org/gmane.linux.usb.general/11998 . After
| applying this patch as well as the one mentioned in the thread later
| and the second patch from this series, i can confirm that my
| co-worker's windows machine no longer crashes. Networking still
| doesn't work though.

Nice find Paul... I sent the two patches from that thread on
pending-tracking and rebased andy-tracking, but I didn't find the third.
~ If you can send a pointer I'll add it tomorrow.

Thanks for the hint.

  • -Andy

comment:2 Changed 6 years ago by andy

Yes all three patches are on andy-tracking, but I am not sure our git server is up the last couple of hours I can't contact it over ssh anyway.

comment:3 Changed 6 years ago by psonek

Hi,
i have updated andy-tracking git and the reboot problem seems to be fixed (no more windows crashing). There is still problem that USB networking does not work. The windows control panel shows that the RNDIS device is not working properly. Should i open a new bug for this?

comment:4 Changed 6 years ago by cedric.berger

Which distribution did you test ?

comment:5 Changed 6 years ago by psonek

SHR unstable and Android

comment:6 Changed 5 years ago by psonek

I started thread about this on linux-usb list. Here is url:

http://marc.info/?l=linux-usb&m=123507198413197&w=2

David Brownell asked here for USB level trace log (CATC, Beagle) which i cannot get and points out that the problem is probably in S3C UDC.

comment:7 Changed 5 years ago by arhuaco

  • Owner changed from openmoko-devel to openmoko-kernel
  • Component changed from unknown to System Software

comment:8 Changed 5 years ago by vnevoa

I think this is probably a duplicate of #1279, which has a patch and was closed successfuly.

comment:9 Changed 5 years ago by andy

No it's a different problem, the reboot thing is fixed some weeks ago but it's still broken for actual RNDIS action so we leave the bug open for now.

comment:10 Changed 5 years ago by bam80

It seems like this have been fixed but Om2009 kernel doesn't includes the patch yet:
http://lists.openmoko.org/pipermail/openmoko-kernel/2009-March/009503.html

comment:11 Changed 5 years ago by PaulFertser

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.