Ticket #2216 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Call = there is no sound

Reported by: octavsly Owned by: openmoko-devel
Priority: high Milestone: Om2008.12
Component: unknown Version: GTA02v6
Severity: major Keywords: call, mute, no sound, no audio
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

When I initiate a call, and when the call is progressing, I cannot hear anything, nor I am heard. I never had this problem before. Adjusting the volume via the slide-bar does not change anything.

I have searched through the tickets but I cannot find anyone having the same problem.

I am using the latest stable Om image.

I have also attached a logread file (replacing the test phone number with "xxxxxxxxxx"

root@om-gta02:/media/card/boot# cat /proc/cpuinfo
Processor       : ARM920T rev 0 (v4l)
BogoMIPS        : 199.47
Features        : swp half thumb
CPU implementer : 0x41
CPU architecture: 4T
CPU variant     : 0x1
CPU part        : 0x920
CPU revision    : 0
Cache type      : write-back
Cache clean     : cp15 c7 ops
Cache lockdown  : format A
Cache format    : Harvard
I size          : 16384
I assoc         : 64
I line length   : 32
I sets          : 8
D size          : 16384
D assoc         : 64
D line length   : 32
D sets          : 8

Hardware        : GTA02
Revision        : 0360
Serial          : 0000000000000000

Attachments

logread (9.3 KB) - added by octavsly 10 years ago.
logread dump, not really showing what is happening :-(
current.state.during_call (16.9 KB) - added by octavsly 10 years ago.

Change History

Changed 10 years ago by octavsly

logread dump, not really showing what is happening :-(

comment:1 follow-up: ↓ 2 Changed 10 years ago by lindi

Can you run "alsactl -f current.state store" during call and attach "current.state" to this bug report?

comment:2 in reply to: ↑ 1 Changed 10 years ago by octavsly

Replying to lindi:

Can you run "alsactl -f current.state store" during call and attach "current.state" to this bug report?

Updated (testing branch) and rebooted. The problem is gone.
When I will have again the issue, I will attach it.

comment:3 Changed 10 years ago by octavsly

OK, it worked when I called,
but when I was called I could not hear anything.

Before teh call, the profile was set to "Vibrate and Ring" but I could not hear the ring. Phone was only vibrating.

Attached you may find the
current.state.during_call (which is the same as before the call)

Changed 10 years ago by octavsly

comment:4 Changed 10 years ago by lindi

Yes it seems that alsa state is not changed for some reason, I do not have knowledge on debugging om 2008.12 issues further.

comment:5 Changed 10 years ago by xbaldauf

This bug still persists as of http://git.openmoko.org/?p=kernel.git;a=commit;h=5b3137236f5d5665774f9705220b3fe6c1e23692 ( Fri, 30 Jan 2009 16:23:54 +0000 (16:23 +0000) ):

  • no sound when phoning
  • no sound when the phone is ringing
  • no sound when doing playback by mplayer

comment:6 Changed 10 years ago by octavsly

as a workaround I use only Vibrate profile (NOT Vibrate and Ring)

comment:7 Changed 10 years ago by xbaldauf

But is phoning possible when using the "Vibrate" profile?

comment:8 Changed 10 years ago by octavsly

Yes. I hear and I am heard.

I presume that if you do not play any sound, e.g. ringing, alarm, calendar, mediaplayer, etc. then you will still be able to call.

comment:9 Changed 10 years ago by mzanetti

For me, this happened after some hours of uptime. Sometimes already after 10 mins of uptime. The very first phonecall after rebooting was working most of the times.

Anyways, I have been able to work around this issue by using Korbinian's workaround for the openmoocow-not-mooing issue. It consists basically of switching speech-dispatcher from alsa to oss. After switching, all 2008.12 sound issues are gone - at least on my FR.

See this URL for a detailed description:
http://lists.openmoko.org/nabble.html#nabble-td2175057

comment:10 Changed 10 years ago by xbaldauf

As of http://git.openmoko.org/?p=kernel.git;a=commit;h=9029dff1f370018665a6e2999632a34fd0518f4d ( Thu, 5 Feb 2009 17:01:56 +0000 (17:01 +0000) ), I can hear sound when phoning and I can hear sound when doing playback by mplayer. I did not testing ringing or speaking into the phone, but I expect this to work. :-) So for me, the bug seems to be fixed. :-)

comment:11 Changed 10 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

Great, thanks for confirming it.

Note: See TracTickets for help on using tickets.