Ticket #2235 (closed defect: fixed)

Opened 9 years ago

Last modified 8 years ago

Monochrome display on resume

Reported by: zeroedout Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version:
Severity: normal Keywords: display, resume
Cc: alishams@…, testing@…, andy@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: yes PatchReviewResult:
Reproducible:

Description

After resuming from a suspend, colour goes away and I am left with only monochrome. Steps to reproduce are just to suspend then resume. This happens with auto-suspending and apm -s. I am using debian and this issue occurs with both uImage-moredrivers-GTA02_stable-b749274fadec33a6.bin and uImage-moredrivers-GTA02_andy-tracking-d1a9cf85c8608601.bin I noticed this with some previous andy tracking kernels. Attached is the dmesg of both after a suspend. Andy latest is d1a9cf85c8608601

Attachments

andy_stable_dmesg.log (34.3 KB) - added by zeroedout 9 years ago.
andy_latest_dmesg.log (35.5 KB) - added by zeroedout 9 years ago.

Change History

Changed 9 years ago by zeroedout

Changed 9 years ago by zeroedout

comment:1 Changed 9 years ago by Karrde

I have also seen this same behavior on my Freerunner. It seems to be somehow related to the Qi, as I have never seen it with any u-boot. I have tried various kernels from the 2.6.24 that comes with the 2008.12 to .28 and .29 kernels, either pre or self build but on resume I get either black and white screen, WSoD or rarely normal colors.

The behavior doesn't seem to be affected whether I boot from the flash or from the uSD card.

comment:2 Changed 9 years ago by arhuaco

  • Owner changed from openmoko-devel to openmoko-kernel
  • Keywords display, resume added
  • Version unspecified deleted
  • Component changed from unknown to System Software

comment:3 Changed 9 years ago by andy

The difference with Qi is that it while it brings up the Glamo, it doesn't bring up the LCM ASIC since it only inits the Glamo to get SD Card access.

So it'd be Qi "not doing" something there rather than doing something if that's related.

I would guess anything to do with mono display action is a feature of the LCM not the Glamo state. Controlling LCM state is not entirely in control as we learned with the WSOD issue.

comment:4 Changed 9 years ago by cedric.berger

I also had this yesterday, for the first (and only) time.
After resume, display was only black and white.

This was with Qi and Android, Michael Trimarchi's latest version (...v14.jffs2 and kernel-v12.bin -based on 2.6.29 I think-).

(Qi from 5 of ferbruary qi-s3c2442-master_c5c167a7f8f922b6.udfu)

comment:6 Changed 9 years ago by nicolas.dufresne

It's going to look like I only know one single driver in the Kernel, but I think jbt driver is again to blaim.

In 2.6.24 we've have worked around a sticky WSOD by not bringing the LCM into deep standby (only bring it to sleep). This work around has worked nicely so far, but in 2.6.29 it's different. We do have the workaround, meaning that on suspend we go to sleep (and not deep standby), but on resume we hard reset the line (the new) and travel through every initialisation.

With locking still terribly weak in this driver, I'm not really surprise resume works only once on two tries (that's what I'm getting).

I'm doing some testing with better locking. I'll try both using deap standby and sleep (removing the reset when only going to sleep state). I should have more input this weekend. Also, it would be nice to review the locking in other graphic components.

comment:7 Changed 9 years ago by nicolas.dufresne

comment:8 Changed 9 years ago by Nytowl

  • HasPatchForReview set

comment:9 Changed 9 years ago by wendy_hung

  • Cc testing@…, andy@… added

Hi,
We don't see this problem in our phones, then we don't know how to test this...
Does this fix for anyone then we can close this ticket?

comment:10 Changed 9 years ago by andy

I have Nicolas' patch on andy-tracking since yesterday.

What we should do is wait a while for someone else who saw it to confirm they don't see it any more when using a kernel with the patch.

The LCM problems are very difficult because different LCMs act differently -- according to temperature as well -- so the issues are not always reproducible in a simple way. But the problems are still real.

comment:11 Changed 9 years ago by rhk

I bumped to this today the first time - after installing Qi. I'm running -24 kernel with 2008.12. I don't have the skills to try the patch..

comment:12 Changed 9 years ago by nicolas.dufresne

Andy could you update the kernel image have on your share on people.openmoko.org/andy, this way users will be able to test it.

comment:13 Changed 9 years ago by andy

Right this second FIQ/HDQ is broken so battery will not give the right info, but I have updated it.

comment:14 Changed 9 years ago by jancona

I also saw this for the first time today after installing Qi. I am using Michael Trimarchi's freerunner-v14.6.jffs2 Android image and his uImage-v13.bin, but I've been using this combo for several days without seeing this problem, so it seems Qi-related.

comment:15 Changed 9 years ago by zeroedout

Looks like the patch worked for my phone! Fixed with uImage-moredrivers-GTA02_andy-tracking-5457a45a5d4ca2c3.bin Full colour after resume, yay!

comment:16 Changed 8 years ago by PaulFertser

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.