Ticket #2262 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

backlight brightness of 11 unusable after blank/unblank

Reported by: lindi Owned by: openmoko-kernel
Priority: normal Milestone: stable-kernel-2009.1
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Steps to reproduce:
1) run Xorg
2) sudo sh -c 'echo 11 > /sys/class/backlight/gta02-bl/brightness'
3) xset s 10
4) sleep 10
5) xset s reset

Expected results:
If screen is readable after 2) then it is also readable after 5)

Actual results:
Screen is readable (although very dim) after 2) but completely blank after 5).

More info:
1) Setting backlight brithness to 12 or higher does not seem to cause this bug.
2) This bug also occurs with Xglamo
3) If you wonder why this is a problem: I was using FR in a car at night and wanted to use very dim display so that I don't disturb the driver. After the screensaver hit blanked the display I was forced to remove the battery to get the phone back to a usable state since using touchscreen blindly to increase backlight brightness was quite impossible and error-prone in my case.

kernel: Linux ginger 2.6.28-GTA02_lindi-andy-tracking_b8b36e5ec3db71d5-mokodev #53 PREEMPT Sun Feb 22 13:08:50 UTC 2009 armv4tl GNU/Linux
kernel cmdline: rootfstype=jffs2 root=/dev/mtdblock6 console=ttySAC2,115200 console=tty0 loglevel=8 regular_boot mtdparts=physmap-flash:-(nor);neo1973-nand:0x00040000(u-boot),0x00040000(u-boot_env),0x00800000(kernel),0x000a0000(splash),0x00040000(factory),0x0f6a0000(rootfs) rootfstype=ext2 root=/dev/mmcblk0p2 rootdelay=5 panic=10 mem=127M
u-boot: U-Boot 1.3.2+gitr46+dc633f4be2527f844158aa5085c278b0c3039d3f (Aug  8 2008 - 03:58:49)
xglamo: 1.3.0.0+git20080807-3
hardware revision:  0350
xserver-xorg-core: 2:1.5.99.902-1
xf86-video-glamo: 703acea1

Change History

comment:1 Changed 6 years ago by lindi

I can still reproduce this with andy-tracking c1b03e4da22e8dd7. I heard from IRC that bumbl does not see this bug with SHR using http://buildhost.shr-project.org/shr-unstable/images/om-gta02/uImage-2.6.28-oe1+gitr119783+901d73fe51f33032b34b2ae5612eb863ec90532a-r3.1-om-gta02.bin
but I wonder if he uses the same setup as I do (Xorg and not having frameworkd control brightness).

comment:2 Changed 6 years ago by arhuaco

  • Milestone set to stable-kernel-2009.1

comment:3 Changed 6 years ago by arhuaco

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 6 years ago by lindi

Thanks a lot. I tested with andy-tracking b4136a36f31a65d0 and can confirm that the bug does not occur anymore.

Note: See TracTickets for help on using tickets.