Ticket #2272 (in_testing defect)

Opened 9 years ago

Last modified 9 years ago

Paroli doesn't lauch at boot after opkg upgrade

Reported by: iknowjoseph Owned by: Nytowl
Priority: normal Milestone: Om2009
Component: unknown Version: unspecified
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I successfully completed an opkg upgrade which provided the following output:

Collected errors:

  • ERROR: Cannot satisfy the following dependencies for libpixman-1-0:

o libgcc-s1 (>= 4.1.2) *

  • Package libelementary-themes wants to install file /usr/share/elementary/themes/default.edj

But that file is already provided by package * paroli

  • Package paroli wants to install file /usr/share/enlightenment/data/themes/illume.edj

But that file is already provided by package * e-wm-theme-illume

  • Package paroli wants to install file /usr/share/enlightenment/data/config/illume/module.illume.cfg

But that file is already provided by package * e-wm-config-illume

  • Package paroli wants to install file /usr/share/enlightenment/data/config/illume/e.cfg

But that file is already provided by package * e-wm-config-illume

root@om-gta02:~#

Upon reboot the phone did not enter Paroli but displayed the Illume themed desktop. Launching Paroli from the icon worked without issue, although a small Illume panel remains at the top of the screen with "Paroli" just visible on the left hand edge.

Attachments

paroli.png (30.4 KB) - added by iknowjoseph 9 years ago.

Change History

Changed 9 years ago by iknowjoseph

comment:1 Changed 9 years ago by Nytowl

  • Owner changed from openmoko-devel to Nytowl
  • Status changed from new to accepted

Which package did you install that had the libpixman dependency ?

If you do a

opkg install -force-reinstall -force-overwrie paroli paroli-autostart and paroli-theme

you will be back to the original look. However today's feed kills your keyboard

comment:2 Changed 9 years ago by iknowjoseph

Libpixman was a dependency from TangoGPS.

The opkg install -force-reinstall -force-overwrite worked fine - the keyboard even remains working as it should.

comment:3 Changed 9 years ago by Nytowl

tango gps from the unstable feeds ?

comment:4 Changed 9 years ago by Nytowl

  • Status changed from accepted to in_testing
  • Milestone set to Om2009
Note: See TracTickets for help on using tickets.