Ticket #2294 (closed defect: fixed)

Opened 8 years ago

Last modified 5 months ago

xf86-video-glamo: stopping X can crash the whole system (not even JTAG works)

Reported by: lindi Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords: xf86-video-glamo WSOD Xorg
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Steps to reproduce:
1) sudo gdb
2) attach <pid-of-X>
3) break GlamoRestoreHW
4) continue
5) sudo kill pidof X
6) continue
7) continue
8) continue
9) continue

Expected results:
6-8) gdb stops due to three signals
9) gdb stops at GlamoRestoreHW and shows its prompt

Actual results:
6-9) gdb stops due to three signals and at GlamoRestoreHW. However, gdb is unable to show its prompt and the whole system stops responding. Even JTAG stops working:

(gdb) break GlamoRestoreHW
Breakpoint 1 at 0x405658b0: file glamo-driver.c, line 744.
(gdb) c
Continuing.

Program received signal SIGTERM, Terminated.
[Switching to Thread 0x40021c50 (LWP 1476)]
0x4039ffe4 in select () from /lib/libc.so.6
(gdb) c
Continuing.

Program received signal SIGTERM, Terminated.
0x000efac4 in ?? ()
(gdb) c
Continuing.

Program received signal SIGCONT, Continued.
0x000efd7c in GiveUp? ()
(gdb)
Continuing.

Breakpoint 1, GlamoRestoreHW (pScrn=0x1c02f8) at glamo-driver.c:744

More info:
1) xf86-video-glamo 451398a21
2) linux 9ecc089861ab238e
3) GDB is not strictly needed here. It is used here just to slow down Xorg so that it hits the bug always:

--- Log opened Sun May 10 08:23:26 2009
08:23 <lars_> i just updated to the newest kernel and i get a wsod every time i quit X

Change History

comment:1 Changed 8 years ago by lars

  • Status changed from new to closed
  • Resolution set to fixed

The problem was caused by turning of the glamo memory clock and has been fixed with commit 69ccc9307c6b6a1aeb1f51ea732af20d52a66685

Closing as fixed

comment:2 Changed 5 months ago by RoberMync

Levitra 60 Mg <a href=http://prozac.ccrpdc.com/fluoxetine.php>?Fluoxetine</a> Direct Progesterone Medication Mastercard Pharmacy Forum Cialis O Viagra <a href=http://cial1.xyz/buy-cheap-cialis-site.php>Buy Cheap Cialis Site</a> Cost Of Viagra Amoxicillin Package Insert <a href=http://kama1.xyz/kamagra-online.php>Kamagra Online</a> Ventajas Del Kamagra Viagra 40 For 99 <a href=http://kama1.xyz/where-can-i-buy-kamagra.php>Where Can I Buy Kamagra</a> Levitra Durata Terapia Propecia Itchy <a href=http://kama1.xyz/cheap-kamagra-pill.php>Cheap Kamagra Pill</a> Cialis Kaufen Online Amoxicillin Reaction In Infants <a href=http://kama1.xyz/kamagra-en-ligne.php>Kamagra En Ligne</a> Priligy Ne Fonctionne Pas Viagra Acheter En Ligne France <a href=http://zol1.xyz/sertralina-generic.php>Sertralina Generic</a> Propecia Cancer Risk Order generic isotretinoin low price internet overseas <a href=http://zol1.xyz/generic-for-zoloft.php>Generic For Zoloft</a> Keflex To Treat Arthritis Zithromax Flu <a href=http://cial1.xyz/how-to-order-cialis.php>How To Order Cialis</a> Viagra Generico Por Internet Amoxicillin 875 Milligrams <a href=http://viag1.xyz/sildenafil-100mg.php>Sildenafil 100mg</a> Prezzo Viagra Farmacia Cialis Viagra <a href=http://cial1.xyz/buy-cialis-cheap.php>Buy Cialis Cheap</a> Zithromax Bleeding Gums Generic Viagra Super Active 100mg <a href=http://zol1.xyz/low-cost-zoloft-online.php>Low Cost Zoloft Online</a> Zithromax Vs Azithromycin Cephalexin Indications And Uses <a href=http://kama1.xyz/cheapest-kamagra.php>Cheapest Kamagra</a> Rxdiler Eric leighton leighton These criminals must be put into life imprisonment because they are very harmful for the Biafran nat. <a href=http://easymoneyfast365.com>bad credit loans</a> is regulated by the Central Please see our calculators below which help you Our branch staff or phone banking team can discuss your options and help with your application This handy loan calculator can give you an estimate of how much you could borrow with a Personal Loan from AIB Please click here Pay for Music Pockets by ICICI Bank Upgrade Debit Card PL on Credit Card More Rates Service Charges Fees ICICI Linkedin Page Your chosen bank account will get debited instantaneously Privilege Personal Internet Banking Services Offered Click to Pay Online Loans Payments Using Net Banking Pay bills and invoices from any bank account or any card Find ATM Branch Rates and Charges Interest Rates Gold Rate Today Service Charges and Fees Tools and Calculators Transfer funds see account details shop and lot more.Levitra Selbst Gemacht <a href=http://cial1.xyz/cialis-buy.php>Cialis Buy</a> Non Prescription Viagra Generic Secure Site For Viagra 100 Mg <a href=http://zoloft.ccrpdc.com/buy-generic-zoloft-online.php>Buy Generic Zoloft Online</a> Cialis 20mg Filmtabletten Einnahme Comprar Cialis En Gijon <a href=http://cial1.xyz/cheap-generic-cialis.php>Cheap Generic Cialis</a> Amoxicillin And Cephalexan Cialis O Viagra Cual Comprar <a href=http://cial5mg.xyz/order-cialis-online-usa.php>Order Cialis Online Usa</a> Finasterida Y Propecia Overdose Fluoxetine <a href=http://zol1.xyz/generic-zoloft-pricing.php>Generic Zoloft Pricing</a> Clobetasol 30g Eczema Wolverhampton Cialis 5mg Canada <a href=http://cial1.xyz/buy-cialis-online-usa.php>Buy Cialis Online Usa</a> Composicion Propecia Cephalexin Behavioral Side Effects <a href=http://zol1.xyz/how-to-buy-zoloft.php>How To Buy Zoloft</a> Buy Kamagra Uk Amoxicillin And Creatine <a href=http://kama1.xyz/kamagra-oral-jelly.php>Kamagra Oral Jelly</a> Zithromax Gastrointestinal Side Effects

Note: See TracTickets for help on using tickets.