Ticket #246 (closed defect: fixed)

Opened 10 years ago

Last modified 8 years ago

Debug board needs to be recognized by mainline linux kernel.

Reported by: stefan@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: default component Version: Version 2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

That's easy just add the IDs to the driver.

Attachments

openmoko-debug-board-ids.patch (1.4 KB) - added by stefan@… 10 years ago.
Add IDs to the driver

Change History

Changed 10 years ago by stefan@…

Add IDs to the driver

comment:1 Changed 10 years ago by stefan@…

Unfortunately is is not that easy. The board uses only one port as a serial
port. The driver should only report one /dev/ttyUSB*

comment:2 Changed 9 years ago by tick@…

  • Status changed from new to closed
  • Resolution set to fixed

close it since it has not been touched for a long time

comment:3 Changed 9 years ago by tick@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

It's still a bug and reopen it.

comment:4 Changed 9 years ago by tick@…

  • Status changed from reopened to closed
  • Resolution set to later

Leave this later

comment:5 Changed 9 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution later deleted

please leave this bug open. it is a bug, and unless it's present in bugzilla,
nobody will ever even bother to fix it.

comment:6 Changed 9 years ago by tick@…

  • Status changed from reopened to new
  • Owner changed from sean_chiang@… to willie_chen@…

comment:7 Changed 9 years ago by roh

  • Owner changed from willie_chen@… to willie_chen

comment:8 Changed 8 years ago by john_lee

  • Owner changed from willie_chen to openmoko-kernel
  • Status changed from new to assigned
  • HasPatchForReview unset

willie_chen doesn't work for us anymore.

comment:9 Changed 8 years ago by laforge

  • Status changed from assigned to closed
  • Resolution set to fixed

this bug has been fixed in the mainline kernel, see git commit message 20734345b35a5ff661293fcca1e376522bcf01de from january 01, 2008

Note: See TracTickets for help on using tickets.