Ticket #249 (closed enhancement: fixed)

Opened 12 years ago

Last modified 12 years ago

add command to print gsmd version number

Reported by: laforge@… Owned by: laforge@…
Priority: high Milestone:
Component: gsmd Version: current svn head
Severity: minor Keywords:
Cc: buglog@…, jserv@…, kevinh@…, matt.mets@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

add command to print gsmd version number (this should be the svn revision currently)

run-time interfaces to obtain the revision number would also be nice, for
daemon, library and libgsmd-util

Attachments

addversioning.patch (1.5 KB) - added by matt.mets@… 12 years ago.
Implement a gsmd version number scheme
gsmd_version.patch (1.5 KB) - added by matt.mets@… 12 years ago.
Add support for the -V version command line argument
gsmd_version.2.patch (1.2 KB) - added by matt.mets@… 12 years ago.
Use BUILT_SOURCES as asuggested by Rodolphe

Change History

comment:1 Changed 12 years ago by kevinh@…

  • Cc kevinh@… added

Changed 12 years ago by matt.mets@…

Implement a gsmd version number scheme

comment:2 Changed 12 years ago by matt.mets@…

I just realized that I missed the initial problem description entirely. My
apologies for not seeing it. I will modify my patch to use the SVN revision and
to provide a run-time interface as requested.

comment:3 Changed 12 years ago by matt.mets@…

  • Cc matt.mets@… added

comment:4 Changed 12 years ago by matt.mets@…

  • attachments.isobsolete changed from 0 to 1

(From update of attachment 206)
Wrong way to implement this, use the next patch version

comment:5 Changed 12 years ago by matt.mets@…

(From update of attachment 206)
Wrong way to implement this, use the next patch version

comment:6 Changed 12 years ago by matt.mets@…

(From update of attachment 206)
Wrong way to implement this, use the next patch version

comment:7 Changed 12 years ago by rodolphe.ortalo@…

Just a small remark, I wonder if
noinst_PROGRAMS = gsmd-version.h
should not be
BUILT_SOURCES= gsmd-version.h
in your modification to Makefile.am?

(see: http://www.gnu.org/software/automake/manual/html_node/Sources.html )

Changed 12 years ago by matt.mets@…

Add support for the -V version command line argument

comment:8 Changed 12 years ago by matt.mets@…

  • attachments.isobsolete changed from 0 to 1

comment:9 Changed 12 years ago by jserv@…

  • Cc jserv@… added

comment:10 Changed 12 years ago by alphaone@…

  • Status changed from new to closed
  • Resolution set to fixed

Patch applied in r2727. Thanks!

Note: See TracTickets for help on using tickets.